]> Dogcows Code - chaz/yoink/blobdiff - yajl/Makefile.am
no more useless singleton class
[chaz/yoink] / yajl / Makefile.am
index 8b359e1310403f93ee984835f7c4348346c6f3ac..e2e7c520c5fc8234d8064182f4d3ebcbc60184a2 100644 (file)
@@ -1,25 +1,25 @@
 
 # To make yajl works as a convenience library, the directory src/api must be
-# renamed to src/yajl, and any sources or headers which refer to headers in in
-# that directory will need to be modified to look in the new directory.
+# renamed to src/yajl, and any sources or headers which refer to headers in that
+# directory will need to be modified to look in the new directory.
 
-noinst_LIBRARIES = libyajl.a
+noinst_LTLIBRARIES = libyajl.la
 
-libyajl_a_SOURCES = \
-                                       src/yajl.c \
-                                       src/yajl_alloc.c \
-                                       src/yajl_alloc.h \
-                                       src/yajl_buf.c \
-                                       src/yajl_buf.h \
-                                       src/yajl_bytestack.h \
-                                       src/yajl_encode.c \
-                                       src/yajl_encode.h \
-                                       src/yajl_gen.c \
-                                       src/yajl_lex.c \
-                                       src/yajl_lex.h \
-                                       src/yajl_parser.c \
-                                       src/yajl_parser.h \
-                                       $(ENDLIST)
+libyajl_la_SOURCES = \
+                                        src/yajl.c \
+                                        src/yajl_alloc.c \
+                                        src/yajl_alloc.h \
+                                        src/yajl_buf.c \
+                                        src/yajl_buf.h \
+                                        src/yajl_bytestack.h \
+                                        src/yajl_encode.c \
+                                        src/yajl_encode.h \
+                                        src/yajl_gen.c \
+                                        src/yajl_lex.c \
+                                        src/yajl_lex.h \
+                                        src/yajl_parser.c \
+                                        src/yajl_parser.h \
+                                        $(ENDLIST)
 
 noinst_HEADERS = \
                                 src/yajl/yajl_common.h \
@@ -27,5 +27,5 @@ noinst_HEADERS = \
                                 src/yajl/yajl_parse.h \
                                 $(ENDLIST)
 
-libyajl_a_CPPFLAGS = -Isrc
+libyajl_la_CPPFLAGS = -Isrc
 
This page took 0.018982 seconds and 4 git commands to generate.