]> Dogcows Code - chaz/yoink/blobdiff - src/Moof/yajl/Makefile.am
added missing licenses
[chaz/yoink] / src / Moof / yajl / Makefile.am
diff --git a/src/Moof/yajl/Makefile.am b/src/Moof/yajl/Makefile.am
new file mode 100644 (file)
index 0000000..f10788a
--- /dev/null
@@ -0,0 +1,32 @@
+
+# Here is an automake file which can be used to build yajl as a convenience
+# library.  I also had to rename src/api to src/yajl and change cpp include
+# directives accordingly in order to allow clients to use the more appropriate
+# #include <yajl/yajl_parse.h> syntax.  -- Chaz
+
+noinst_LTLIBRARIES = libyajl.la
+
+libyajl_la_SOURCES = \
+                                        src/yajl.c \
+                                        src/yajl_alloc.c \
+                                        src/yajl_alloc.h \
+                                        src/yajl_buf.c \
+                                        src/yajl_buf.h \
+                                        src/yajl_bytestack.h \
+                                        src/yajl_encode.c \
+                                        src/yajl_encode.h \
+                                        src/yajl_gen.c \
+                                        src/yajl_lex.c \
+                                        src/yajl_lex.h \
+                                        src/yajl_parser.c \
+                                        src/yajl_parser.h \
+                                        $(ENDLIST)
+
+noinst_HEADERS = \
+                                src/yajl/yajl_common.h \
+                                src/yajl/yajl_gen.h \
+                                src/yajl/yajl_parse.h \
+                                $(ENDLIST)
+
+libyajl_la_CPPFLAGS = -Isrc
+
This page took 0.023295 seconds and 4 git commands to generate.