]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
new level-based controllers
[chaz/yoink] / src / Makefile.am
index 30f2bae88f3cbeb2ed24f4f21770e056e11f4475..ff318048071729560a868139f5663ef688b64c44 100644 (file)
@@ -36,6 +36,7 @@ libmoof_a_SOURCES = \
                                        Moof/Hash.cc \
                                        Moof/Hash.hh \
                                        Moof/Interpolator.hh \
+                                       Moof/Layer.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
                                        Moof/Math.hh \
@@ -54,6 +55,7 @@ libmoof_a_SOURCES = \
                                        Moof/RK4.hh \
                                        Moof/Scene.cc \
                                        Moof/Scene.hh \
+                                       Moof/Script.hh \
                                        Moof/Serializable.cc \
                                        Moof/Serializable.hh \
                                        Moof/Serializer.cc \
@@ -109,16 +111,24 @@ bin_PROGRAMS = yoink
 yoink_SOURCES = \
                                Character.cc \
                                Character.hh \
+                               GameLayer.cc \
+                               GameLayer.hh \
                                Hud.cc \
                                Hud.hh \
+                               MainLayer.cc \
+                               MainLayer.hh \
                                TilemapFont.cc \
                                TilemapFont.hh \
                                Typesetter.cc \
                                Typesetter.hh \
-                               YoinkApp.cc \
-                               YoinkApp.hh \
                                $(ENDLIST)
 
+if WIN32
+yoink_SOURCES += yoink.rc yoink.ico
+.rc.o:
+       @WINDRES@ -o $@ -i $<
+endif
+
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
 yoink_LDADD = libmoof.a
 
This page took 0.019276 seconds and 4 git commands to generate.