]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
fixed layer bugs; generalized octree
[chaz/yoink] / src / Makefile.am
index 30f2bae88f3cbeb2ed24f4f21770e056e11f4475..aeab798dfe4ce2260a775e77037d67749e2378bd 100644 (file)
@@ -36,11 +36,11 @@ libmoof_a_SOURCES = \
                                        Moof/Hash.cc \
                                        Moof/Hash.hh \
                                        Moof/Interpolator.hh \
+                                       Moof/Layer.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
                                        Moof/Math.hh \
                                        Moof/Mippleton.hh \
-                                       Moof/Octree.cc \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
                                        Moof/Plane.cc \
@@ -52,8 +52,7 @@ libmoof_a_SOURCES = \
                                        Moof/Resource.cc \
                                        Moof/Resource.hh \
                                        Moof/RK4.hh \
-                                       Moof/Scene.cc \
-                                       Moof/Scene.hh \
+                                       Moof/Script.hh \
                                        Moof/Serializable.cc \
                                        Moof/Serializable.hh \
                                        Moof/Serializer.cc \
@@ -73,6 +72,7 @@ libmoof_a_SOURCES = \
                                        Moof/Tilemap.hh \
                                        Moof/Timer.cc \
                                        Moof/Timer.hh \
+                                       Moof/Transition.hh \
                                        Moof/Video.cc \
                                        Moof/Video.hh \
                                        Moof/fastevents.c \
@@ -109,16 +109,30 @@ bin_PROGRAMS = yoink
 yoink_SOURCES = \
                                Character.cc \
                                Character.hh \
+                               GameLayer.cc \
+                               GameLayer.hh \
+                               Heroine.cc \
+                               Heroine.hh \
                                Hud.cc \
                                Hud.hh \
+                               MainLayer.cc \
+                               MainLayer.hh \
+                               Scene.cc \
+                               Scene.hh \
                                TilemapFont.cc \
                                TilemapFont.hh \
+                               TitleLayer.cc \
+                               TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
-                               YoinkApp.cc \
-                               YoinkApp.hh \
                                $(ENDLIST)
 
+if WIN32
+yoink_SOURCES += yoink.rc yoink.ico
+.rc.o:
+       @WINDRES@ -o $@ -i $<
+endif
+
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
 yoink_LDADD = libmoof.a
 
This page took 0.017493 seconds and 4 git commands to generate.