]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
now can create win32 portable packages
[chaz/yoink] / src / Makefile.am
index c10b58660c566f214cd5f2be93b85b76451373b6..9a7f5146e454789933ca73128d720488f1e5429d 100644 (file)
@@ -7,53 +7,53 @@
 
 #
 # libmoof.a
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 noinst_LIBRARIES = libmoof.a
 
 libmoof_a_SOURCES = \
-                                       Moof/Aabb.cc \
                                        Moof/Aabb.hh \
+                                       Moof/Backend.cc \
+                                       Moof/Backend.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
+                                       Moof/Contact.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
                                        Moof/Cullable.hh \
-                                       Moof/Dispatcher.cc \
-                                       Moof/Dispatcher.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
-                                       Moof/Engine.cc \
-                                       Moof/Engine.hh \
                                        Moof/Entity.hh \
+                                       Moof/Error.hh \
                                        Moof/Event.hh \
-                                       Moof/Exception.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
-                                       Moof/Hash.cc \
-                                       Moof/Hash.hh \
+                                       Moof/HashTools.cc \
+                                       Moof/HashTools.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
                                        Moof/Interpolator.hh \
-                                       Moof/Layer.hh \
-                                       Moof/Library.hh \
+                                       Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
+                                       Moof/Manager.hh \
                                        Moof/Math.hh \
+                                       Moof/ModalDialog.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
-                                       Moof/Random.cc \
-                                       Moof/Random.hh \
-                                       Moof/Rectangle.cc \
-                                       Moof/Rectangle.hh \
+                                       Moof/Ray.hh \
                                        Moof/Resource.cc \
                                        Moof/Resource.hh \
                                        Moof/RigidBody.hh \
                                        Moof/Script.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
+                                       Moof/Shape.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
-                                       Moof/Sphere.cc \
                                        Moof/Sphere.hh \
                                        Moof/StringTools.cc \
                                        Moof/StringTools.hh \
@@ -62,9 +62,10 @@ libmoof_a_SOURCES = \
                                        Moof/Thread.hh \
                                        Moof/Timer.cc \
                                        Moof/Timer.hh \
-                                       Moof/Transition.hh \
                                        Moof/Video.cc \
                                        Moof/Video.hh \
+                                       Moof/View.cc \
+                                       Moof/View.hh \
                                        Moof/fastevents.c \
                                        Moof/fastevents.h \
                                        $(ENDLIST)
@@ -76,7 +77,7 @@ EXTRA_DIST = Moof/cml Moof/stlplus
 
 #
 # yoink
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 bin_PROGRAMS = yoink
 
@@ -85,31 +86,33 @@ yoink_SOURCES = \
                                Animation.hh \
                                Character.cc \
                                Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
+                               GameState.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
                                Hud.hh \
-                               MainLayer.cc \
-                               MainLayer.hh \
+                               Main.cc \
+                               Main.hh \
                                Scene.cc \
                                Scene.hh \
-                               Tilemap.cc \
-                               Tilemap.hh \
                                TilemapFont.cc \
                                TilemapFont.hh \
                                TitleLayer.cc \
                                TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
+                               version.c \
                                version.h \
                                $(ENDLIST)
 
 if WIN32
 yoink_SOURCES += yoink.rc yoink.ico
 .rc.o:
-       @WINDRES@ -o $@ -i $<
+       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
 endif
 
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
@@ -122,5 +125,5 @@ run: all
        $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
-       $(YOINK_ENVIRONMENT) gdb ./yoink
+       $(YOINK_ENVIRONMENT) ddd ./yoink
 
This page took 0.023133 seconds and 4 git commands to generate.