]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
repository reorganizing
[chaz/yoink] / src / Makefile.am
index 4e8f65d0b26b0f47d252050332843f7e227426cd..98cf9b91e804e3ae52377c093b9a13719352fa8c 100644 (file)
 
 noinst_LIBRARIES = libmoof.a
 
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
+
 libmoof_a_SOURCES = \
+                                       Moof/Aabb.cc \
                                        Moof/Aabb.hh \
+                                       Moof/Backend.cc \
+                                       Moof/Backend.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
+                                       Moof/Contact.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
-                                       Moof/Core.cc \
-                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
                                        Moof/Dispatch.cc \
                                        Moof/Dispatch.hh \
@@ -28,12 +32,11 @@ libmoof_a_SOURCES = \
                                        Moof/Event.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
-                                       Moof/Hash.cc \
-                                       Moof/Hash.hh \
+                                       Moof/HashTools.cc \
+                                       Moof/HashTools.hh \
                                        Moof/Image.cc \
                                        Moof/Image.hh \
                                        Moof/Interpolator.hh \
-                                       Moof/Layer.hh \
                                        Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
@@ -62,15 +65,14 @@ libmoof_a_SOURCES = \
                                        Moof/Thread.hh \
                                        Moof/Timer.cc \
                                        Moof/Timer.hh \
-                                       Moof/Transition.hh \
                                        Moof/Video.cc \
                                        Moof/Video.hh \
+                                       Moof/View.cc \
+                                       Moof/View.hh \
                                        Moof/fastevents.c \
                                        Moof/fastevents.h \
                                        $(ENDLIST)
 
-libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
-
 EXTRA_DIST = Moof/cml Moof/stlplus
 
 
@@ -80,6 +82,9 @@ EXTRA_DIST = Moof/cml Moof/stlplus
 
 bin_PROGRAMS = yoink
 
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD = libmoof.a
+
 yoink_SOURCES = \
                                Animation.cc \
                                Animation.hh \
@@ -89,6 +94,7 @@ yoink_SOURCES = \
                                ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
+                               GameState.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
@@ -108,14 +114,13 @@ yoink_SOURCES = \
                                $(ENDLIST)
 
 if WIN32
-yoink_SOURCES += yoink.rc yoink.ico
-.rc.o:
-       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
-endif
 
-yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
-yoink_LDADD = libmoof.a
+yoink_SOURCES += yoink.rc
 
+.rc.o:
+       $(WINDRES) -o $@ -i $<
+
+else
 
 YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
 
@@ -125,3 +130,5 @@ run: all
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
 
+endif
+
This page took 0.019874 seconds and 4 git commands to generate.