]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
fixes for newer versions of g++
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..61be61016885df1ad74557f77e2a17cf15b18503 100644 (file)
@@ -1,6 +1,140 @@
 
+#
+# Yoink
+# Process this file with automake to produce a Makefile.
+#
+
+
+#
+# libmoof.a
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+noinst_LIBRARIES = libmoof.a
+
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/moof
+
+libmoof_a_SOURCES = \
+                                       moof/aabb.cc \
+                                       moof/aabb.hh \
+                                       moof/backend.cc \
+                                       moof/backend.hh \
+                                       moof/camera.cc \
+                                       moof/camera.hh \
+                                       moof/contact.hh \
+                                       moof/ConvertUTF.c \
+                                       moof/ConvertUTF.h \
+                                       moof/cullable.hh \
+                                       moof/dispatcher.cc \
+                                       moof/dispatcher.hh \
+                                       moof/drawable.hh \
+                                       moof/entity.hh \
+                                       moof/event.hh \
+                                       moof/frustum.cc \
+                                       moof/frustum.hh \
+                                       moof/hash.cc \
+                                       moof/hash.hh \
+                                       moof/image.cc \
+                                       moof/image.hh \
+                                       moof/interpolator.hh \
+                                       moof/line.hh \
+                                       moof/log.cc \
+                                       moof/log.hh \
+                                       moof/manager.hh \
+                                       moof/math.hh \
+                                       moof/modal_dialog.hh \
+                                       moof/network.hh \
+                                       moof/opengl.hh \
+                                       moof/packet.cc \
+                                       moof/packet.hh \
+                                       moof/plane.cc \
+                                       moof/plane.hh \
+                                       moof/ray.hh \
+                                       moof/resource.cc \
+                                       moof/resource.hh \
+                                       moof/rigid_body.hh \
+                                       moof/script.hh \
+                                       moof/service.cc \
+                                       moof/service.hh \
+                                       moof/settings.cc \
+                                       moof/settings.hh \
+                                       moof/shape.hh \
+                                       moof/socket.hh \
+                                       moof/sound.cc \
+                                       moof/sound.hh \
+                                       moof/sphere.hh \
+                                       moof/string.cc \
+                                       moof/string.hh \
+                                       moof/texture.cc \
+                                       moof/texture.hh \
+                                       moof/thread.hh \
+                                       moof/timer.cc \
+                                       moof/timer.hh \
+                                       moof/video.cc \
+                                       moof/video.hh \
+                                       moof/view.cc \
+                                       moof/view.hh \
+                                       moof/fastevents.c \
+                                       moof/fastevents.h \
+                                       $(ENDLIST)
+
+EXTRA_DIST = moof/cml moof/stlplus
+
+
+#
+# yoink
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
 bin_PROGRAMS = yoink
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+yoink_CPPFLAGS = -I$(top_srcdir)/src/moof
+yoink_LDADD = libmoof.a
+
+yoink_SOURCES = \
+                               Animation.cc \
+                               Animation.hh \
+                               Character.cc \
+                               Character.hh \
+                               GameLayer.cc \
+                               GameLayer.hh \
+                               GameState.hh \
+                               Heroine.cc \
+                               Heroine.hh \
+                               Hud.cc \
+                               Hud.hh \
+                               Main.cc \
+                               Main.hh \
+                               Scene.cc \
+                               Scene.hh \
+                               TilemapFont.cc \
+                               TilemapFont.hh \
+                               TitleLayer.cc \
+                               TitleLayer.hh \
+                               Typesetter.cc \
+                               Typesetter.hh \
+                               version.c \
+                               version.h \
+                               $(ENDLIST)
+
+if WIN32
+yoink_SOURCES += yoink.rc
+.rc.o:
+       $(WINDRES) -o $@ -i $<
+else
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
+run: all
+       $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
+
+debug: all
+       $(YOINK_ENVIRONMENT) gdb ./yoink
+endif
+
+if LINK_SH
+yoink$(EXEEXT): $(yoink_OBJECTS) $(yoink_DEPENDENCIES)
+       @rm -f yoink$(EXEEXT)
+       @LINK="$(CXXLINK) $(yoink_OBJECTS) $(yoink_LDADD) $(LIBS)"\
+               sh $(top_srcdir)/link.sh
+
+clean-local:
+       rm -f .link/*
+endif
 
This page took 0.025727 seconds and 4 git commands to generate.