]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
arch linux prefers pkgconfig for finding lua
[chaz/yoink] / src / Makefile.am
index 7c4e61c83cbd7bbf095f9e67c6d44030a165d675..4e8f65d0b26b0f47d252050332843f7e227426cd 100644 (file)
@@ -7,53 +7,53 @@
 
 #
 # libmoof.a
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 noinst_LIBRARIES = libmoof.a
 
 libmoof_a_SOURCES = \
-                                       Moof/Aabb.cc \
                                        Moof/Aabb.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
+                                       Moof/Core.cc \
+                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
-                                       Moof/Dispatcher.cc \
-                                       Moof/Dispatcher.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
-                                       Moof/Engine.cc \
-                                       Moof/Engine.hh \
                                        Moof/Entity.hh \
+                                       Moof/Error.hh \
                                        Moof/Event.hh \
-                                       Moof/Exception.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
                                        Moof/Hash.cc \
                                        Moof/Hash.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
                                        Moof/Interpolator.hh \
                                        Moof/Layer.hh \
+                                       Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
+                                       Moof/Manager.hh \
                                        Moof/Math.hh \
-                                       Moof/Mippleton.hh \
+                                       Moof/ModalDialog.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
-                                       Moof/Random.cc \
-                                       Moof/Random.hh \
-                                       Moof/Rectangle.cc \
-                                       Moof/Rectangle.hh \
+                                       Moof/Ray.hh \
                                        Moof/Resource.cc \
                                        Moof/Resource.hh \
-                                       Moof/RK4.hh \
+                                       Moof/RigidBody.hh \
                                        Moof/Script.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
+                                       Moof/Shape.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
-                                       Moof/Sphere.cc \
                                        Moof/Sphere.hh \
                                        Moof/StringTools.cc \
                                        Moof/StringTools.hh \
@@ -76,7 +76,7 @@ EXTRA_DIST = Moof/cml Moof/stlplus
 
 #
 # yoink
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 bin_PROGRAMS = yoink
 
@@ -85,31 +85,32 @@ yoink_SOURCES = \
                                Animation.hh \
                                Character.cc \
                                Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
                                Hud.hh \
-                               MainLayer.cc \
-                               MainLayer.hh \
+                               Main.cc \
+                               Main.hh \
                                Scene.cc \
                                Scene.hh \
-                               Tilemap.cc \
-                               Tilemap.hh \
                                TilemapFont.cc \
                                TilemapFont.hh \
                                TitleLayer.cc \
                                TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
+                               version.c \
                                version.h \
                                $(ENDLIST)
 
 if WIN32
 yoink_SOURCES += yoink.rc yoink.ico
 .rc.o:
-       @WINDRES@ -o $@ -i $<
+       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
 endif
 
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
This page took 0.022007 seconds and 4 git commands to generate.