]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
arch linux prefers pkgconfig for finding lua
[chaz/yoink] / src / Makefile.am
index 766d4ce1480b0d00da9b4b63eb5d6d813dc569db..4e8f65d0b26b0f47d252050332843f7e227426cd 100644 (file)
@@ -7,36 +7,37 @@
 
 #
 # libmoof.a
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 noinst_LIBRARIES = libmoof.a
 
 libmoof_a_SOURCES = \
-                                       Moof/Aabb.cc \
                                        Moof/Aabb.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
+                                       Moof/Core.cc \
+                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
                                        Moof/Dispatch.cc \
                                        Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
-                                       Moof/Engine.cc \
-                                       Moof/Engine.hh \
                                        Moof/Entity.hh \
+                                       Moof/Error.hh \
                                        Moof/Event.hh \
-                                       Moof/Exception.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
                                        Moof/Hash.cc \
                                        Moof/Hash.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
                                        Moof/Interpolator.hh \
                                        Moof/Layer.hh \
-                                       Moof/Library.hh \
                                        Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
+                                       Moof/Manager.hh \
                                        Moof/Math.hh \
                                        Moof/ModalDialog.hh \
                                        Moof/Octree.hh \
@@ -44,8 +45,6 @@ libmoof_a_SOURCES = \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
                                        Moof/Ray.hh \
-                                       Moof/Rectangle.cc \
-                                       Moof/Rectangle.hh \
                                        Moof/Resource.cc \
                                        Moof/Resource.hh \
                                        Moof/RigidBody.hh \
@@ -77,7 +76,7 @@ EXTRA_DIST = Moof/cml Moof/stlplus
 
 #
 # yoink
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 bin_PROGRAMS = yoink
 
@@ -94,12 +93,10 @@ yoink_SOURCES = \
                                Heroine.hh \
                                Hud.cc \
                                Hud.hh \
-                               MainLayer.cc \
-                               MainLayer.hh \
+                               Main.cc \
+                               Main.hh \
                                Scene.cc \
                                Scene.hh \
-                               Tilemap.cc \
-                               Tilemap.hh \
                                TilemapFont.cc \
                                TilemapFont.hh \
                                TitleLayer.cc \
This page took 0.018622 seconds and 4 git commands to generate.