]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
cade lab fixes
[chaz/yoink] / src / Makefile.am
index e2ea2fe75e30ecf5f81151bfef2fba156088c06a..3c3fc5312c697cb34540d039fb8c9f9dfdbdc00b 100644 (file)
@@ -18,19 +18,21 @@ libmoof_a_SOURCES = \
                                        Moof/Camera.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
+                                       Moof/Core.cc \
+                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
                                        Moof/Dispatch.cc \
                                        Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
-                                       Moof/Engine.cc \
-                                       Moof/Engine.hh \
                                        Moof/Entity.hh \
+                                       Moof/Error.hh \
                                        Moof/Event.hh \
-                                       Moof/Exception.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
                                        Moof/Hash.cc \
                                        Moof/Hash.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
                                        Moof/Interpolator.hh \
                                        Moof/Layer.hh \
                                        Moof/Library.hh \
@@ -94,8 +96,8 @@ yoink_SOURCES = \
                                Heroine.hh \
                                Hud.cc \
                                Hud.hh \
-                               MainLayer.cc \
-                               MainLayer.hh \
+                               Main.cc \
+                               Main.hh \
                                Scene.cc \
                                Scene.hh \
                                Tilemap.cc \
@@ -113,7 +115,7 @@ yoink_SOURCES = \
 if WIN32
 yoink_SOURCES += yoink.rc yoink.ico
 .rc.o:
-       @WINDRES@ -o $@ -i $<
+       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
 endif
 
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
@@ -128,6 +130,3 @@ run: all
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
 
-all-local:     # always rebuild version.c
-       @touch version.c
-
This page took 0.021973 seconds and 4 git commands to generate.