]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
cade lab fixes
[chaz/yoink] / src / Makefile.am
index c10b58660c566f214cd5f2be93b85b76451373b6..3c3fc5312c697cb34540d039fb8c9f9dfdbdc00b 100644 (file)
@@ -18,31 +18,34 @@ libmoof_a_SOURCES = \
                                        Moof/Camera.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
+                                       Moof/Core.cc \
+                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
-                                       Moof/Dispatcher.cc \
-                                       Moof/Dispatcher.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
-                                       Moof/Engine.cc \
-                                       Moof/Engine.hh \
                                        Moof/Entity.hh \
+                                       Moof/Error.hh \
                                        Moof/Event.hh \
-                                       Moof/Exception.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
                                        Moof/Hash.cc \
                                        Moof/Hash.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
                                        Moof/Interpolator.hh \
                                        Moof/Layer.hh \
                                        Moof/Library.hh \
+                                       Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
                                        Moof/Math.hh \
+                                       Moof/ModalDialog.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
-                                       Moof/Random.cc \
-                                       Moof/Random.hh \
+                                       Moof/Ray.hh \
                                        Moof/Rectangle.cc \
                                        Moof/Rectangle.hh \
                                        Moof/Resource.cc \
@@ -51,9 +54,9 @@ libmoof_a_SOURCES = \
                                        Moof/Script.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
+                                       Moof/Shape.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
-                                       Moof/Sphere.cc \
                                        Moof/Sphere.hh \
                                        Moof/StringTools.cc \
                                        Moof/StringTools.hh \
@@ -85,14 +88,16 @@ yoink_SOURCES = \
                                Animation.hh \
                                Character.cc \
                                Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
                                Hud.hh \
-                               MainLayer.cc \
-                               MainLayer.hh \
+                               Main.cc \
+                               Main.hh \
                                Scene.cc \
                                Scene.hh \
                                Tilemap.cc \
@@ -103,13 +108,14 @@ yoink_SOURCES = \
                                TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
+                               version.c \
                                version.h \
                                $(ENDLIST)
 
 if WIN32
 yoink_SOURCES += yoink.rc yoink.ico
 .rc.o:
-       @WINDRES@ -o $@ -i $<
+       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
 endif
 
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
This page took 0.019433 seconds and 4 git commands to generate.