]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
new win32 resource file; better dependency checks
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..384fa0a55c1fb9801902834431829d02d074cae0 100644 (file)
@@ -1,6 +1,139 @@
 
+#
+# Yoink
+# Process this file with automake to produce a Makefile.
+#
+
+
+#
+# libmoof.a
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+noinst_LIBRARIES = libmoof.a
+
+libmoof_a_SOURCES = \
+                                       Moof/Aabb.cc \
+                                       Moof/Aabb.hh \
+                                       Moof/Animation.cc \
+                                       Moof/Animation.hh \
+                                       Moof/Camera.cc \
+                                       Moof/Camera.hh \
+                                       Moof/ConvertUTF.c \
+                                       Moof/ConvertUTF.h \
+                                       Moof/Cullable.hh \
+                                       Moof/Deserializer.cc \
+                                       Moof/Deserializer.hh \
+                                       Moof/Dispatcher.cc \
+                                       Moof/Dispatcher.hh \
+                                       Moof/Drawable.hh \
+                                       Moof/Engine.cc \
+                                       Moof/Engine.hh \
+                                       Moof/Entity.hh \
+                                       Moof/Event.hh \
+                                       Moof/Exception.hh \
+                                       Moof/Frustum.cc \
+                                       Moof/Frustum.hh \
+                                       Moof/Hash.cc \
+                                       Moof/Hash.hh \
+                                       Moof/Interpolator.hh \
+                                       Moof/Log.cc \
+                                       Moof/Log.hh \
+                                       Moof/Math.hh \
+                                       Moof/Mippleton.hh \
+                                       Moof/Octree.cc \
+                                       Moof/Octree.hh \
+                                       Moof/OpenGL.hh \
+                                       Moof/Plane.cc \
+                                       Moof/Plane.hh \
+                                       Moof/Random.cc \
+                                       Moof/Random.hh \
+                                       Moof/Rectangle.cc \
+                                       Moof/Rectangle.hh \
+                                       Moof/Resource.cc \
+                                       Moof/Resource.hh \
+                                       Moof/RK4.hh \
+                                       Moof/Scene.cc \
+                                       Moof/Scene.hh \
+                                       Moof/Serializable.cc \
+                                       Moof/Serializable.hh \
+                                       Moof/Serializer.cc \
+                                       Moof/Serializer.hh \
+                                       Moof/Settings.cc \
+                                       Moof/Settings.hh \
+                                       Moof/Sound.cc \
+                                       Moof/Sound.hh \
+                                       Moof/Sphere.cc \
+                                       Moof/Sphere.hh \
+                                       Moof/StringTools.cc \
+                                       Moof/StringTools.hh \
+                                       Moof/Texture.cc \
+                                       Moof/Texture.hh \
+                                       Moof/Thread.hh \
+                                       Moof/Tilemap.cc \
+                                       Moof/Tilemap.hh \
+                                       Moof/Timer.cc \
+                                       Moof/Timer.hh \
+                                       Moof/Video.cc \
+                                       Moof/Video.hh \
+                                       Moof/fastevents.c \
+                                       Moof/fastevents.h \
+                                       $(ENDLIST)
+
+libmoof_a_SOURCES += \
+                                        Moof/yajl/src/yajl.c \
+                                        Moof/yajl/src/yajl_alloc.c \
+                                        Moof/yajl/src/yajl_alloc.h \
+                                        Moof/yajl/src/yajl_buf.c \
+                                        Moof/yajl/src/yajl_buf.h \
+                                        Moof/yajl/src/yajl_bytestack.h \
+                                        Moof/yajl/src/yajl_encode.c \
+                                        Moof/yajl/src/yajl_encode.h \
+                                        Moof/yajl/src/yajl_gen.c \
+                                        Moof/yajl/src/yajl_lex.c \
+                                        Moof/yajl/src/yajl_lex.h \
+                                        Moof/yajl/src/yajl_parser.c \
+                                        Moof/yajl/src/yajl_parser.h \
+                                        $(ENDLIST)
+
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof -I$(top_srcdir)/src/Moof/yajl/src
+
+EXTRA_DIST = Moof/cml Moof/stlplus Moof/yajl
+
+
+#
+# yoink
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
 bin_PROGRAMS = yoink
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+yoink_SOURCES = \
+                               Character.cc \
+                               Character.hh \
+                               Hud.cc \
+                               Hud.hh \
+                               TilemapFont.cc \
+                               TilemapFont.hh \
+                               Typesetter.cc \
+                               Typesetter.hh \
+                               YoinkApp.cc \
+                               YoinkApp.hh \
+                               $(ENDLIST)
+
+if WIN32
+yoink_SOURCES += yoink.rc yoink.ico
+.rc.o:
+       @WINDRES@ -o $@ -i $<
+endif
+
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD = libmoof.a
+
+
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
+
+run: all
+       $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
+
+debug: all
+       $(YOINK_ENVIRONMENT) gdb ./yoink
 
This page took 0.019459 seconds and 4 git commands to generate.