]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
initial working frustum culling implementation
[chaz/yoink] / src / Makefile.am
index 0826767c3f359dc3102789f2ae163466d5212491..1d320e691cbbd2a87a753e02555722f21258f6a7 100644 (file)
@@ -2,9 +2,11 @@
 noinst_LTLIBRARIES = libmoof.la
 
 libmoof_la_SOURCES = \
+                                  Moof/Aabb.cc \
                                   Moof/Aabb.hh \
                                   Moof/Animation.cc \
                                   Moof/Animation.hh \
+                                  Moof/Camera.cc \
                                   Moof/Camera.hh \
                                   Moof/ConvertUTF.c \
                                   Moof/ConvertUTF.h \
@@ -16,12 +18,20 @@ libmoof_la_SOURCES = \
                                   Moof/Drawable.hh \
                                   Moof/Engine.cc \
                                   Moof/Engine.hh \
+                                  Moof/Entity.hh \
                                   Moof/Event.hh \
+                                  Moof/Frustum.cc \
+                                  Moof/Frustum.hh \
+                                  Moof/Hash.cc \
+                                  Moof/Hash.hh \
                                   Moof/Interpolator.hh \
                                   Moof/Math.hh \
                                   Moof/Mippleton.hh \
+                                  Moof/Octree.hh \
                                   Moof/OpenGL.cc \
                                   Moof/OpenGL.hh \
+                                  Moof/Plane.cc \
+                                  Moof/Plane.hh \
                                   Moof/Profiler.hh \
                                   Moof/Random.cc \
                                   Moof/Random.hh \
@@ -36,6 +46,8 @@ libmoof_la_SOURCES = \
                                   Moof/Settings.cc \
                                   Moof/Settings.hh \
                                   Moof/Singleton.hh \
+                                  Moof/Sphere.cc \
+                                  Moof/Sphere.hh \
                                   Moof/StringTools.cc \
                                   Moof/StringTools.hh \
                                   Moof/Texture.cc \
@@ -45,6 +57,7 @@ libmoof_la_SOURCES = \
                                   Moof/Tilemap.hh \
                                   Moof/Timer.cc \
                                   Moof/Timer.hh \
+                                  Moof/Tree.hh \
                                   Moof/Video.cc \
                                   Moof/Video.hh \
                                   Moof/fastevents.c \
@@ -75,11 +88,10 @@ yoink_LDADD    = libmoof.la
 EXTRA_DIST = Moof/cml
 
 
-YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data" \
-                                       YOINKRC="$(top_srcdir)/data/yoinkrc"
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
 
 run: all
-       $(YOINK_ENVIRONMENT) ./yoink
+       $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
This page took 0.018773 seconds and 4 git commands to generate.