]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
beginnings of scene rendering
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..0c9b062b892dff0e614e8e0a69ead4133e625120 100644 (file)
@@ -1,6 +1,82 @@
 
-bin_PROGRAMS = yoink
+noinst_LTLIBRARIES = libdc.la
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+libdc_la_SOURCES = \
+                                  ConvertUTF.c \
+                                  ConvertUTF.h \
+                                  aabb.hh \
+                                  animation.cc \
+                                  animation.hh \
+                                  deserializer.cc \
+                                  deserializer.hh \
+                                  dispatcher.cc \
+                                  dispatcher.hh \
+                                  drawable.hh \
+                                  engine.cc \
+                                  engine.hh \
+                                  event.hh \
+                                  fastevents.c \
+                                  fastevents.h \
+                                  interpolator.hh \
+                                  math.hh \
+                                  mippleton.hh \
+                                  opengl.hh \
+                                  profiler.hh \
+                                  random.cc \
+                                  random.hh \
+                                  resource.cc \
+                                  resource.hh \
+                                  scene.cc \
+                                  scene.hh \
+                                  serializable.cc \
+                                  serializable.hh \
+                                  serializer.cc \
+                                  serializer.hh \
+                                  settings.cc \
+                                  settings.hh \
+                                  singleton.hh \
+                                  stringtools.cc \
+                                  stringtools.hh \
+                                  texture.cc \
+                                  texture.hh \
+                                  thread.hh \
+                                  tilemap.cc \
+                                  tilemap.hh \
+                                  timer.cc \
+                                  timer.hh \
+                                  video.cc \
+                                  video.hh \
+                                  $(ENDLIST)
+
+libdc_la_CPPFLAGS = -I$(top_srcdir)/yajl/src
+libdc_la_LIBADD   = $(top_srcdir)/yajl/libyajl.la
+
+
+bin_PROGRAMS   = yoink
+
+yoink_SOURCES  = \
+                                Character.cc \
+                                Character.hh \
+                                TilemapFont.cc \
+                                TilemapFont.hh \
+                                Typesetter.cc \
+                                Typesetter.hh \
+                                YoinkApp.cc \
+                                YoinkApp.hh \
+                                $(ENDLIST)
+
+yoink_LDADD    = libdc.la
+
+
+EXTRA_DIST = cml
+
+
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data" \
+                                       YOINKRC="$(top_srcdir)/data/yoinkrc"
+
+run: all
+       $(YOINK_ENVIRONMENT) ./yoink
+
+debug: all
+       $(YOINK_ENVIRONMENT) gdb ./yoink
 
This page took 0.018678 seconds and 4 git commands to generate.