]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
tar: live within system-supplied limits on file descriptors
[chaz/tar] / tests / Makefile.am
index 6b394d12ffc0b787009557ef46f3cbd8c1892c18..ea1c6aee60fe9eb35a555df70abcad95bbb8bc64 100644 (file)
@@ -1,14 +1,14 @@
 # Makefile for GNU tar regression tests.
 
-# Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005, 
-# 2006 Free Software Foundation, Inc.
+# Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005,
+# 2006, 2007, 2009 Free Software Foundation, Inc.
 
 # François Pinard <pinard@iro.umontreal.ca>, 1988.
 # Sergey Poznyakoff <gray@mirddin.farlep.net>, 2004.
 
 ## This program is free software; you can redistribute it and/or modify
 ## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
+## the Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 
 ## This program is distributed in the hope that it will be useful,
@@ -46,10 +46,13 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
 ## ------------ ##
 
 TESTSUITE_AT = \
+ T-empty.at\
+ T-null.at\
  testsuite.at\
  append.at\
  append01.at\
  append02.at\
+ backup01.at\
  chtype.at\
  comprec.at\
  delete01.at\
@@ -57,23 +60,49 @@ TESTSUITE_AT = \
  delete03.at\
  delete04.at\
  delete05.at\
+ exclude.at\
+ exclude01.at\
+ exclude02.at\
+ exclude03.at\
+ exclude04.at\
+ exclude05.at\
+ exclude06.at\
  extrac01.at\
  extrac02.at\
  extrac03.at\
  extrac04.at\
  extrac05.at\
  extrac06.at\
+ extrac07.at\
+ extrac08.at\
+ extrac09.at\
+ extrac10.at\
+ extrac11.at\
+ filerem01.at\
+ filerem02.at\
  gzip.at\
+ grow.at\
  incremental.at\
  incr01.at\
  incr02.at\
  incr03.at\
  incr04.at\
+ incr05.at\
+ incr06.at\
  indexfile.at\
  ignfail.at\
+ label01.at\
+ label02.at\
+ label03.at\
+ label04.at\
+ label05.at\
  link01.at\
+ link02.at\
+ link03.at\
+ link04.at\
  listed01.at\
  listed02.at\
+ listed03.at\
  long01.at\
  longv7.at\
  lustar01.at\
@@ -84,6 +113,9 @@ TESTSUITE_AT = \
  multiv03.at\
  multiv04.at\
  multiv05.at\
+ multiv06.at\
+ multiv07.at\
+ multiv08.at\
  old.at\
  options.at\
  options02.at\
@@ -92,9 +124,17 @@ TESTSUITE_AT = \
  rename01.at\
  rename02.at\
  rename03.at\
+ rename04.at\
+ rename05.at\
+ remfiles01.at\
+ remfiles02.at\
+ remfiles03.at\
  same-order01.at\
  same-order02.at\
+ shortfile.at\
+ shortupd.at\
  shortrec.at\
+ sigpipe.at\
  sparse01.at\
  sparse02.at\
  sparse03.at\
@@ -105,9 +145,14 @@ TESTSUITE_AT = \
  spmvp10.at\
  truncate.at\
  update.at\
+ update01.at\
+ update02.at\
  volsize.at\
  volume.at\
+ verbose.at\
  version.at\
+ xform-h.at\
+ xform01.at\
  star/gtarfail.at\
  star/gtarfail2.at\
  star/multi-fail.at\
@@ -129,7 +174,7 @@ clean-local:
        test ! -f $(TESTSUITE) || $(SHELL) $(TESTSUITE) --clean
 
 check-local: atconfig atlocal $(TESTSUITE)
-       $(SHELL) $(TESTSUITE)
+       $(SHELL) $(TESTSUITE) $(TESTSUITEFLAGS)
 
 check-full:
        FULL_TEST=1 $(MAKE) check
@@ -138,7 +183,7 @@ check-full:
 
 # Run the test suite on the *installed* tree.
 installcheck-local:
-       $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
+       $(SHELL) $(TESTSUITE) $(TESTSUITEFLAGS) AUTOTEST_PATH=$(exec_prefix)/bin
 
 
 ## ------------ ##
@@ -150,6 +195,6 @@ check_PROGRAMS = genfile
 genfile_SOURCES = genfile.c argcv.c argcv.h
 
 localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../lib -I$(top_srcdir)/src
+INCLUDES = -I$(top_srcdir)/gnu -I../gnu -I$(top_srcdir)/gnu -I$(top_srcdir)/lib
 AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
-LDADD = ../lib/libtar.a $(LIBINTL) $(LIB_CLOCK_GETTIME)
+LDADD = ../gnu/libgnu.a $(LIBINTL) $(LIB_CLOCK_GETTIME)
This page took 0.026322 seconds and 4 git commands to generate.