]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
Support for POSIX ACLs
[chaz/tar] / tests / Makefile.am
index 33edd0e549f04b884752b8e411b03f5d9fc5d658..e97c5086f47bbc923a2cd16651fc4c9559381041 100644 (file)
@@ -1,14 +1,14 @@
 # Makefile for GNU tar regression tests.
 
-# Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005, 
-# 2006 Free Software Foundation, Inc.
+# Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005,
+# 2006, 2007, 2009, 2012 Free Software Foundation, Inc.
 
 # François Pinard <pinard@iro.umontreal.ca>, 1988.
 # Sergey Poznyakoff <gray@mirddin.farlep.net>, 2004.
 
 ## This program is free software; you can redistribute it and/or modify
 ## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
+## the Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 
 ## This program is distributed in the hope that it will be useful,
@@ -52,6 +52,8 @@ TESTSUITE_AT = \
  append.at\
  append01.at\
  append02.at\
+ append03.at\
+ backup01.at\
  chtype.at\
  comprec.at\
  delete01.at\
@@ -59,6 +61,14 @@ TESTSUITE_AT = \
  delete03.at\
  delete04.at\
  delete05.at\
+ exclude.at\
+ exclude01.at\
+ exclude02.at\
+ exclude03.at\
+ exclude04.at\
+ exclude05.at\
+ exclude06.at\
+ exclude07.at\
  extrac01.at\
  extrac02.at\
  extrac03.at\
@@ -66,6 +76,20 @@ TESTSUITE_AT = \
  extrac05.at\
  extrac06.at\
  extrac07.at\
+ extrac08.at\
+ extrac09.at\
+ extrac10.at\
+ extrac11.at\
+ extrac12.at\
+ extrac13.at\
+ extrac14.at\
+ extrac15.at\
+ extrac16.at\
+ extrac17.at\
+ extrac18.at\
+ extrac19.at\
+ filerem01.at\
+ filerem02.at\
  gzip.at\
  grow.at\
  incremental.at\
@@ -73,11 +97,24 @@ TESTSUITE_AT = \
  incr02.at\
  incr03.at\
  incr04.at\
+ incr05.at\
+ incr06.at\
  indexfile.at\
  ignfail.at\
+ label01.at\
+ label02.at\
+ label03.at\
+ label04.at\
+ label05.at\
  link01.at\
+ link02.at\
+ link03.at\
+ link04.at\
  listed01.at\
  listed02.at\
+ listed03.at\
+ listed04.at\
+ listed05.at\
  long01.at\
  longv7.at\
  lustar01.at\
@@ -88,20 +125,33 @@ TESTSUITE_AT = \
  multiv03.at\
  multiv04.at\
  multiv05.at\
+ multiv06.at\
+ multiv07.at\
+ multiv08.at\
  old.at\
  options.at\
  options02.at\
+ owner.at\
  pipe.at\
  recurse.at\
  rename01.at\
  rename02.at\
  rename03.at\
+ rename04.at\
+ rename05.at\
+ remfiles01.at\
+ remfiles02.at\
+ remfiles03.at\
  same-order01.at\
  same-order02.at\
+ shortfile.at\
+ shortupd.at\
  shortrec.at\
+ sigpipe.at\
  sparse01.at\
  sparse02.at\
  sparse03.at\
+ sparse04.at\
  sparsemv.at\
  sparsemvp.at\
  spmvp00.at\
@@ -109,16 +159,28 @@ TESTSUITE_AT = \
  spmvp10.at\
  truncate.at\
  update.at\
+ update01.at\
+ update02.at\
  volsize.at\
  volume.at\
  verbose.at\
+ verify.at\
  version.at\
+ xform-h.at\
+ xform01.at\
  star/gtarfail.at\
  star/gtarfail2.at\
  star/multi-fail.at\
  star/ustar-big-2g.at\
  star/ustar-big-8g.at\
- star/pax-big-10g.at
+ star/pax-big-10g.at\
+ xattr01.at\
+ xattr02.at\
+ xattr03.at\
+ xattr04.at\
+ acls01.at\
+ acls02.at\
+ capabs_raw01.at
 
 TESTSUITE = $(srcdir)/testsuite
 
@@ -134,7 +196,7 @@ clean-local:
        test ! -f $(TESTSUITE) || $(SHELL) $(TESTSUITE) --clean
 
 check-local: atconfig atlocal $(TESTSUITE)
-       $(SHELL) $(TESTSUITE)
+       $(SHELL) $(TESTSUITE) $(TESTSUITEFLAGS)
 
 check-full:
        FULL_TEST=1 $(MAKE) check
@@ -143,7 +205,7 @@ check-full:
 
 # Run the test suite on the *installed* tree.
 installcheck-local:
-       $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
+       $(SHELL) $(TESTSUITE) $(TESTSUITEFLAGS) AUTOTEST_PATH=$(exec_prefix)/bin
 
 
 ## ------------ ##
@@ -155,6 +217,6 @@ check_PROGRAMS = genfile
 genfile_SOURCES = genfile.c argcv.c argcv.h
 
 localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../lib -I$(top_srcdir)/src
+INCLUDES = -I$(top_srcdir)/gnu -I../gnu -I$(top_srcdir)/gnu -I$(top_srcdir)/lib
 AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
-LDADD = ../lib/libtar.a $(LIBINTL) $(LIB_CLOCK_GETTIME)
+LDADD = ../gnu/libgnu.a $(LIBINTL) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS)
This page took 0.023291 seconds and 4 git commands to generate.