]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
Reduce memory consuption when handling the -T option.
[chaz/tar] / tests / Makefile.am
index 7acc9d6dd4e02c9b1793d5709067b514b178d482..e13b0794b75f2a8fde2e060e9a79902e70a2417d 100644 (file)
@@ -1,25 +1,21 @@
 # Makefile for GNU tar regression tests.
 
-# Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005,
-# 2006, 2007, 2009 Free Software Foundation, Inc.
+# Copyright 1996-1997, 1999-2001, 2003-2007, 2009, 2012-2013 Free Software
 
-# François Pinard <pinard@iro.umontreal.ca>, 1988.
-# Sergey Poznyakoff <gray@mirddin.farlep.net>, 2004.
+# This file is part of GNU tar.
 
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 3, or (at your option)
-## any later version.
+# GNU tar is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
 
-## This program is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-## GNU General Public License for more details.
+# GNU tar is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
 
-## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
-## 02110-1301, USA.
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 EXTRA_DIST = $(TESTSUITE_AT) testsuite package.m4 star/README star/quicktest.sh
 DISTCLEANFILES       = atconfig $(check_SCRIPTS)
@@ -48,6 +44,8 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
 TESTSUITE_AT = \
  T-empty.at\
  T-null.at\
+ T-zfile.at\
+ T-nonl.at\
  testsuite.at\
  append.at\
  append01.at\
@@ -69,6 +67,15 @@ TESTSUITE_AT = \
  exclude05.at\
  exclude06.at\
  exclude07.at\
+ exclude08.at\
+ exclude09.at\
+ exclude10.at\
+ exclude11.at\
+ exclude12.at\
+ exclude13.at\
+ exclude14.at\
+ exclude15.at\
+ exclude16.at\
  extrac01.at\
  extrac02.at\
  extrac03.at\
@@ -86,6 +93,8 @@ TESTSUITE_AT = \
  extrac15.at\
  extrac16.at\
  extrac17.at\
+ extrac18.at\
+ extrac19.at\
  filerem01.at\
  filerem02.at\
  gzip.at\
@@ -112,6 +121,7 @@ TESTSUITE_AT = \
  listed02.at\
  listed03.at\
  listed04.at\
+ listed05.at\
  long01.at\
  longv7.at\
  lustar01.at\
@@ -126,6 +136,12 @@ TESTSUITE_AT = \
  multiv07.at\
  multiv08.at\
  old.at\
+ opcomp01.at\
+ opcomp02.at\
+ opcomp03.at\
+ opcomp04.at\
+ opcomp05.at\
+ opcomp06.at\
  options.at\
  options02.at\
  owner.at\
@@ -154,6 +170,7 @@ TESTSUITE_AT = \
  spmvp00.at\
  spmvp01.at\
  spmvp10.at\
+ time01.at\
  truncate.at\
  update.at\
  update01.at\
@@ -170,7 +187,17 @@ TESTSUITE_AT = \
  star/multi-fail.at\
  star/ustar-big-2g.at\
  star/ustar-big-8g.at\
- star/pax-big-10g.at
+ star/pax-big-10g.at\
+ xattr01.at\
+ xattr02.at\
+ xattr03.at\
+ xattr04.at\
+ xattr05.at\
+ acls01.at\
+ acls02.at\
+ selnx01.at\
+ selacl01.at\
+ capabs_raw01.at
 
 TESTSUITE = $(srcdir)/testsuite
 
@@ -207,6 +234,11 @@ check_PROGRAMS = genfile
 genfile_SOURCES = genfile.c argcv.c argcv.h
 
 localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/gnu -I../gnu -I$(top_srcdir)/gnu -I$(top_srcdir)/lib
-AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/gnu\
+ -I../gnu\
+ -I$(top_srcdir)/gnu\
+ -I$(top_srcdir)/lib\
+ -DLOCALEDIR=\"$(localedir)\"
+
 LDADD = ../gnu/libgnu.a $(LIBINTL) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS)
This page took 0.028277 seconds and 4 git commands to generate.