]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
testsuite: add test for buggy default ACLs
[chaz/tar] / tests / Makefile.am
index 14ed47cc95af0e10ae335438045ef6fcec86458a..76954eb05df35380dca2c5450c1614a3d5dc0cf6 100644 (file)
@@ -1,25 +1,21 @@
 # Makefile for GNU tar regression tests.
 
-# Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005 Free Software
-# Foundation, Inc.
+# Copyright 1996-1997, 1999-2001, 2003-2007, 2009, 2012-2013 Free Software
 
-# François Pinard <pinard@iro.umontreal.ca>, 1988.
-# Sergey Poznyakoff <gray@mirddin.farlep.net>, 2004.
+# This file is part of GNU tar.
 
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
-## any later version.
+# GNU tar is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
 
-## This program is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-## GNU General Public License for more details.
+# GNU tar is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
 
-## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-## 02111-1307, USA.
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 EXTRA_DIST = $(TESTSUITE_AT) testsuite package.m4 star/README star/quicktest.sh
 DISTCLEANFILES       = atconfig $(check_SCRIPTS)
@@ -46,50 +42,193 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
 ## ------------ ##
 
 TESTSUITE_AT = \
+ T-cd.at\
+ T-empty.at\
+ T-null.at\
+ T-rec.at\
+ T-zfile.at\
+ T-nonl.at\
+ T-mult.at\
+ T-nest.at\
  testsuite.at\
  append.at\
  append01.at\
+ append02.at\
+ append03.at\
+ append04.at\
+ backup01.at\
+ chtype.at\
  comprec.at\
  delete01.at\
  delete02.at\
  delete03.at\
  delete04.at\
  delete05.at\
+ exclude.at\
+ exclude01.at\
+ exclude02.at\
+ exclude03.at\
+ exclude04.at\
+ exclude05.at\
+ exclude06.at\
+ exclude07.at\
+ exclude08.at\
+ exclude09.at\
+ exclude10.at\
+ exclude11.at\
+ exclude12.at\
+ exclude13.at\
+ exclude14.at\
+ exclude15.at\
+ exclude16.at\
  extrac01.at\
  extrac02.at\
  extrac03.at\
  extrac04.at\
  extrac05.at\
+ extrac06.at\
+ extrac07.at\
+ extrac08.at\
+ extrac09.at\
+ extrac10.at\
+ extrac11.at\
+ extrac12.at\
+ extrac13.at\
+ extrac14.at\
+ extrac15.at\
+ extrac16.at\
+ extrac17.at\
+ extrac18.at\
+ extrac19.at\
+ filerem01.at\
+ filerem02.at\
  gzip.at\
+ grow.at\
  incremental.at\
+ incr01.at\
+ incr02.at\
+ incr03.at\
+ incr04.at\
+ incr05.at\
+ incr06.at\
+ incr07.at\
+ incr08.at\
+ incr09.at\
+ indexfile.at\
  ignfail.at\
+ label01.at\
+ label02.at\
+ label03.at\
+ label04.at\
+ label05.at\
  link01.at\
+ link02.at\
+ link03.at\
+ link04.at\
  listed01.at\
  listed02.at\
+ listed03.at\
+ listed04.at\
+ listed05.at\
  long01.at\
  longv7.at\
+ lustar01.at\
+ lustar02.at\
+ lustar03.at\
  multiv01.at\
  multiv02.at\
  multiv03.at\
  multiv04.at\
+ multiv05.at\
+ multiv06.at\
+ multiv07.at\
+ multiv08.at\
  old.at\
+ onetop01.at\
+ onetop02.at\
+ onetop03.at\
+ onetop04.at\
+ opcomp01.at\
+ opcomp02.at\
+ opcomp03.at\
+ opcomp04.at\
+ opcomp05.at\
+ opcomp06.at\
  options.at\
  options02.at\
+ owner.at\
  pipe.at\
  recurse.at\
+ rename01.at\
+ rename02.at\
+ rename03.at\
+ rename04.at\
+ rename05.at\
+ remfiles01.at\
+ remfiles02.at\
+ remfiles03.at\
+ remfiles04a.at\
+ remfiles04b.at\
+ remfiles04c.at\
+ remfiles05a.at\
+ remfiles05b.at\
+ remfiles05c.at\
+ remfiles06a.at\
+ remfiles06b.at\
+ remfiles06c.at\
+ remfiles07a.at\
+ remfiles07b.at\
+ remfiles07c.at\
+ remfiles08a.at\
+ remfiles08b.at\
+ remfiles08c.at\
+ remfiles09a.at\
+ remfiles09b.at\
+ remfiles09c.at\
  same-order01.at\
  same-order02.at\
+ shortfile.at\
+ shortupd.at\
  shortrec.at\
+ sigpipe.at\
  sparse01.at\
  sparse02.at\
+ sparse03.at\
+ sparse04.at\
+ sparsemv.at\
+ sparsemvp.at\
+ spmvp00.at\
+ spmvp01.at\
+ spmvp10.at\
+ time01.at\
+ truncate.at\
+ update.at\
+ update01.at\
+ update02.at\
+ volsize.at\
  volume.at\
+ verbose.at\
+ verify.at\
  version.at\
+ xform-h.at\
+ xform01.at\
  star/gtarfail.at\
  star/gtarfail2.at\
  star/multi-fail.at\
  star/ustar-big-2g.at\
  star/ustar-big-8g.at\
- star/pax-big-10g.at
+ star/pax-big-10g.at\
+ xattr01.at\
+ xattr02.at\
+ xattr03.at\
+ xattr04.at\
+ xattr05.at\
+ acls01.at\
+ acls02.at\
+ acls03.at\
+ selnx01.at\
+ selacl01.at\
+ capabs_raw01.at
 
 TESTSUITE = $(srcdir)/testsuite
 
@@ -102,16 +241,19 @@ atconfig: $(top_builddir)/config.status
        cd $(top_builddir) && ./config.status tests/$@
 
 clean-local:
-       $(SHELL) $(TESTSUITE) --clean
+       test ! -f $(TESTSUITE) || $(SHELL) $(TESTSUITE) --clean
 
 check-local: atconfig atlocal $(TESTSUITE)
-       $(SHELL) $(TESTSUITE)
+       $(SHELL) $(TESTSUITE) $(TESTSUITEFLAGS)
+
+check-full:
+       FULL_TEST=1 $(MAKE) check
 
 #check_SCRIPTS = tar
 
 # Run the test suite on the *installed* tree.
 installcheck-local:
-       $(SHELL) $(TESTSUITE) AUTOTEST_PATH=$(exec_prefix)/bin
+       $(SHELL) $(TESTSUITE) $(TESTSUITEFLAGS) AUTOTEST_PATH=$(exec_prefix)/bin
 
 
 ## ------------ ##
@@ -120,10 +262,14 @@ installcheck-local:
 
 check_PROGRAMS = genfile
 
-genfile_SOURCES = genfile.c
+genfile_SOURCES = genfile.c argcv.c argcv.h
 
 localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../lib -I$(top_srcdir)/src
-
-LDADD = ../lib/libtar.a $(LIBINTL)
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/gnu\
+ -I../gnu\
+ -I$(top_srcdir)/gnu\
+ -I$(top_srcdir)/lib\
+ -DLOCALEDIR=\"$(localedir)\"
 
+LDADD = ../gnu/libgnu.a $(LIBINTL) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS)
This page took 0.027271 seconds and 4 git commands to generate.