]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
Don't build ttyemu and run tty I/O test if grantpt is not available.
[chaz/tar] / tests / Makefile.am
index 940c94f3f1823b68c8cb93f4c235bf1e5cbbc7ef..6684d1d89952ef71a4dc60106442b560936d883d 100644 (file)
@@ -116,6 +116,7 @@ TESTSUITE_AT = \
  incr09.at\
  indexfile.at\
  ignfail.at\
+ iotty.at\
  label01.at\
  label02.at\
  label03.at\
@@ -144,6 +145,10 @@ TESTSUITE_AT = \
  multiv07.at\
  multiv08.at\
  old.at\
+ onetop01.at\
+ onetop02.at\
+ onetop03.at\
+ onetop04.at\
  opcomp01.at\
  opcomp02.at\
  opcomp03.at\
@@ -155,6 +160,7 @@ TESTSUITE_AT = \
  owner.at\
  pipe.at\
  recurse.at\
+ recurs02.at\
  rename01.at\
  rename02.at\
  rename03.at\
@@ -163,11 +169,25 @@ TESTSUITE_AT = \
  remfiles01.at\
  remfiles02.at\
  remfiles03.at\
- remfiles04.at\
- remfiles05.at\
- remfiles06.at\
- remfiles07.at\
- remfiles08.at\
+ remfiles04a.at\
+ remfiles04b.at\
+ remfiles04c.at\
+ remfiles05a.at\
+ remfiles05b.at\
+ remfiles05c.at\
+ remfiles06a.at\
+ remfiles06b.at\
+ remfiles06c.at\
+ remfiles07a.at\
+ remfiles07b.at\
+ remfiles07c.at\
+ remfiles08a.at\
+ remfiles08b.at\
+ remfiles08c.at\
+ remfiles09a.at\
+ remfiles09b.at\
+ remfiles09c.at\
+ remfiles10.at\
  same-order01.at\
  same-order02.at\
  shortfile.at\
@@ -208,6 +228,7 @@ TESTSUITE_AT = \
  xattr05.at\
  acls01.at\
  acls02.at\
+ acls03.at\
  selnx01.at\
  selacl01.at\
  capabs_raw01.at
@@ -244,8 +265,14 @@ installcheck-local:
 
 check_PROGRAMS = genfile
 
+if TAR_COND_GRANTPT
+check_PROGRAMS += ttyemu
+endif
+
 genfile_SOURCES = genfile.c argcv.c argcv.h
 
+ttyemu_SOURCES = ttyemu.c
+
 localedir = $(datadir)/locale
 AM_CPPFLAGS = \
  -I$(top_srcdir)/gnu\
This page took 0.021232 seconds and 4 git commands to generate.