]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
Add testcase for the previous commit.
[chaz/tar] / tests / Makefile.am
index be00446b067239aee9a443b2b4c320bf66a6dfd8..2d861ccca4aae07d972e612c93a7e3f32406eccc 100644 (file)
@@ -43,6 +43,8 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
 
 TESTSUITE_AT = \
  T-cd.at\
+ T-dir00.at\
+ T-dir01.at\
  T-empty.at\
  T-null.at\
  T-rec.at\
@@ -116,6 +118,7 @@ TESTSUITE_AT = \
  incr09.at\
  indexfile.at\
  ignfail.at\
+ iotty.at\
  label01.at\
  label02.at\
  label03.at\
@@ -159,6 +162,7 @@ TESTSUITE_AT = \
  owner.at\
  pipe.at\
  recurse.at\
+ recurs02.at\
  rename01.at\
  rename02.at\
  rename03.at\
@@ -185,6 +189,7 @@ TESTSUITE_AT = \
  remfiles09a.at\
  remfiles09b.at\
  remfiles09c.at\
+ remfiles10.at\
  same-order01.at\
  same-order02.at\
  shortfile.at\
@@ -195,6 +200,7 @@ TESTSUITE_AT = \
  sparse02.at\
  sparse03.at\
  sparse04.at\
+ sparse05.at\
  sparsemv.at\
  sparsemvp.at\
  spmvp00.at\
@@ -225,6 +231,7 @@ TESTSUITE_AT = \
  xattr05.at\
  acls01.at\
  acls02.at\
+ acls03.at\
  selnx01.at\
  selacl01.at\
  capabs_raw01.at
@@ -261,8 +268,14 @@ installcheck-local:
 
 check_PROGRAMS = genfile
 
+if TAR_COND_GRANTPT
+check_PROGRAMS += ttyemu
+endif
+
 genfile_SOURCES = genfile.c argcv.c argcv.h
 
+ttyemu_SOURCES = ttyemu.c
+
 localedir = $(datadir)/locale
 AM_CPPFLAGS = \
  -I$(top_srcdir)/gnu\
This page took 0.026825 seconds and 4 git commands to generate.