]> Dogcows Code - chaz/tar/blobdiff - tests/Makefile.am
Migrate to Git
[chaz/tar] / tests / Makefile.am
index bb5ed5136407984b0f0d962a83dd4a9a8a100753..2c13231fb0a42257c6605399f70693d06aa4b005 100644 (file)
@@ -1,14 +1,14 @@
 # Makefile for GNU tar regression tests.
 
 # Copyright (C) 1996, 1997, 1999, 2000, 2001, 2003, 2004, 2005, 
-# 2006 Free Software Foundation, Inc.
+# 2006, 2007, 2009 Free Software Foundation, Inc.
 
 # François Pinard <pinard@iro.umontreal.ca>, 1988.
 # Sergey Poznyakoff <gray@mirddin.farlep.net>, 2004.
 
 ## This program is free software; you can redistribute it and/or modify
 ## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
+## the Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 
 ## This program is distributed in the hope that it will be useful,
@@ -46,6 +46,8 @@ $(srcdir)/package.m4: $(top_srcdir)/configure.ac
 ## ------------ ##
 
 TESTSUITE_AT = \
+ T-empty.at\
+ T-null.at\
  testsuite.at\
  append.at\
  append01.at\
@@ -57,13 +59,16 @@ TESTSUITE_AT = \
  delete03.at\
  delete04.at\
  delete05.at\
+ exclude.at\
  extrac01.at\
  extrac02.at\
  extrac03.at\
  extrac04.at\
  extrac05.at\
  extrac06.at\
+ extrac07.at\
  gzip.at\
+ grow.at\
  incremental.at\
  incr01.at\
  incr02.at\
@@ -83,6 +88,8 @@ TESTSUITE_AT = \
  multiv02.at\
  multiv03.at\
  multiv04.at\
+ multiv05.at\
+ multiv06.at\
  old.at\
  options.at\
  options02.at\
@@ -91,8 +98,12 @@ TESTSUITE_AT = \
  rename01.at\
  rename02.at\
  rename03.at\
+ rename04.at\
+ rename05.at\
  same-order01.at\
  same-order02.at\
+ shortfile.at\
+ shortupd.at\
  shortrec.at\
  sparse01.at\
  sparse02.at\
@@ -106,6 +117,7 @@ TESTSUITE_AT = \
  update.at\
  volsize.at\
  volume.at\
+ verbose.at\
  version.at\
  star/gtarfail.at\
  star/gtarfail2.at\
@@ -149,6 +161,6 @@ check_PROGRAMS = genfile
 genfile_SOURCES = genfile.c argcv.c argcv.h
 
 localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../lib -I$(top_srcdir)/src
+INCLUDES = -I$(top_srcdir)/gnu -I../gnu -I$(top_srcdir)/gnu -I$(top_srcdir)/lib
 AM_CPPFLAGS = -DLOCALEDIR=\"$(localedir)\"
-LDADD = ../lib/libtar.a $(LIBINTL) $(LIB_CLOCK_GETTIME)
+LDADD = ../gnu/libgnu.a $(LIBINTL) $(LIB_CLOCK_GETTIME)
This page took 0.023498 seconds and 4 git commands to generate.