]> Dogcows Code - chaz/tar/blobdiff - src/Makefile.am
Update copyright years.
[chaz/tar] / src / Makefile.am
index 0e813f3382c4e7ad2106a3c8879c87dcf3d225fa..fa24b94b093cc2ba46d282cb1d1c2f6025ee1c9d 100644 (file)
@@ -1,62 +1,53 @@
 # Makefile for GNU tar sources.
 
-# Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003 Free
+# Copyright 1994-1997, 1999-2001, 2003, 2006-2007, 2009, 2013-2014 Free
 # Software Foundation, Inc.
 
-## This program is free software; you can redistribute it and/or modify
-## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
-## any later version.
+# This file is part of GNU tar.
 
-## This program is distributed in the hope that it will be useful,
-## but WITHOUT ANY WARRANTY; without even the implied warranty of
-## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-## GNU General Public License for more details.
+# GNU tar is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
 
-## You should have received a copy of the GNU General Public License
-## along with this program; if not, write to the Free Software
-## Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-## 02111-1307, USA.
+# GNU tar is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
 
 bin_PROGRAMS = tar
-rmtdir=$(DEFAULT_RMT_DIR)
-rmt_PROGRAMS = @RMT@
-EXTRA_PROGRAMS = rmt
 
-noinst_HEADERS = arith.h common.h rmt.h system.h tar.h
-rmt_SOURCES = rmt.c
+noinst_HEADERS = arith.h common.h tar.h xattrs.h
 tar_SOURCES = \
  buffer.c\
+ checkpoint.c\
  compare.c\
  create.c\
  delete.c\
+ exit.c\
  extract.c\
  xheader.c\
  incremen.c\
  list.c\
- mangle.c\
  misc.c\
  names.c\
- rtapelib.c\
  sparse.c\
+ suffix.c\
  system.c\
  tar.c\
+ transform.c\
+ unlink.c\
  update.c\
- utf8.c
-
-localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../lib 
-
-DISTCLEANFILES = localedir.h
-localedir.h : Makefile
-       echo '#define LOCALEDIR "$(localedir)"' >$@
-       echo "#ifndef DEFAULT_RMT_COMMAND" >> $@
-       echo "# define DEFAULT_RMT_COMMAND \"$(rmtdir)/`echo \"rmt\" | sed 's,^.*/,,;$(transform)'`$(EXEEXT)\"" >> $@
-       echo "#endif" >> $@
+ utf8.c\
+ warning.c\
+ xattrs.c
 
-rmt.o tar.o : localedir.h
+AM_CPPFLAGS = -I$(top_srcdir)/gnu -I../ -I../gnu -I$(top_srcdir)/lib -I../lib
+AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-LDADD = ../lib/libtar.a $(LIBINTL)
+LDADD = ../lib/libtar.a ../gnu/libgnu.a $(LIBINTL) $(LIBICONV)
 
-rmt_LDADD = $(LDADD) $(LIB_SETSOCKOPT)
-tar_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME)
+tar_LDADD = $(LIBS) $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS) $(LIB_SELINUX)
This page took 0.025269 seconds and 4 git commands to generate.