]> Dogcows Code - chaz/tar/blobdiff - src/Makefile.am
tar: prefer openat-style functions
[chaz/tar] / src / Makefile.am
index d678fcba7a8b815baf720ca2c9d5d22ec42e9f7d..de310f43512a8dba61bd852aa2eb965a4dc49b91 100644 (file)
@@ -1,51 +1,51 @@
 # Makefile for GNU tar sources.
-# Copyright (C) 1994, 1995, 1996, 1997 Free Software Foundation, Inc.
 
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
+# Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003, 2006,
+# 2007, 2009 Free Software Foundation, Inc.
 
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
-# GNU General Public License for more details.
+## This program is free software; you can redistribute it and/or modify
+## it under the terms of the GNU General Public License as published by
+## the Free Software Foundation; either version 3, or (at your option)
+## any later version.
 
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-# 02111-1307, USA.
+## This program is distributed in the hope that it will be useful,
+## but WITHOUT ANY WARRANTY; without even the implied warranty of
+## MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+## GNU General Public License for more details.
+
+## You should have received a copy of the GNU General Public License
+## along with this program; if not, write to the Free Software
+## Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA
+## 02110-1301, USA.
 
-AUTOMAKE_OPTIONS = gnits ansi2knr
 bin_PROGRAMS = tar
-libexec_PROGRAMS = @RMT@
-EXTRA_PROGRAMS = rmt
-
-noinst_HEADERS = arith.h common.h rmt.h system.h tar.h
-rmt_SOURCES = rmt.c
-tar_SOURCES = arith.c buffer.c compare.c create.c delete.c extract.c \
-incremen.c list.c mangle.c misc.c names.c open3.c rtapelib.c tar.c update.c
-
-INCLUDES = -I../intl -I$(top_srcdir)/lib
-LDADD = ../lib/libtar.a @INTLLIBS@
-localedir = $(prefix)/@DATADIRNAME@/locale
-
-tar.o: tar.c
-       $(COMPILE) -DLOCALEDIR=\"$(localedir)\" -c $(srcdir)/tar.c
-
-tar._o: tar._c
-       @rm -f _tar.c
-       @ln tar._c _tar.c
-       $(COMPILE) -DLOCALEDIR=\"$(localedir)\" -c _tar.c
-       @mv _tar.o $@
-       @rm _tar.c
-
-rmt.o: rmt.c
-       $(COMPILE) -DLOCALEDIR=\"$(localedir)\" -c $(srcdir)/rmt.c
-
-rmt._o: rmt._c
-       @rm -f _rmt.c
-       @ln rmt._c _rmt.c
-       $(COMPILE) -DLOCALEDIR=\"$(localedir)\" -c _rmt.c
-       @mv _rmt.o $@
-       @rm _rmt.c
+
+noinst_HEADERS = arith.h common.h tar.h
+tar_SOURCES = \
+ buffer.c\
+ checkpoint.c\
+ compare.c\
+ create.c\
+ delete.c\
+ exit.c\
+ extract.c\
+ xheader.c\
+ incremen.c\
+ list.c\
+ misc.c\
+ names.c\
+ sparse.c\
+ suffix.c\
+ system.c\
+ tar.c\
+ transform.c\
+ unlink.c\
+ update.c\
+ utf8.c\
+ warning.c
+
+INCLUDES = -I$(top_srcdir)/gnu -I../ -I../gnu -I$(top_srcdir)/lib -I../lib
+
+LDADD = ../lib/libtar.a ../gnu/libgnu.a $(LIBINTL) $(LIBICONV)
+
+tar_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS)
This page took 0.021996 seconds and 4 git commands to generate.