]> Dogcows Code - chaz/tar/blobdiff - src/Makefile.am
tar: prefer openat-style functions
[chaz/tar] / src / Makefile.am
index 46b6fa832b249f01675c745f2edba744409a6ec4..de310f43512a8dba61bd852aa2eb965a4dc49b91 100644 (file)
@@ -1,11 +1,11 @@
 # Makefile for GNU tar sources.
 
-# Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003 Free
-# Software Foundation, Inc.
+# Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003, 2006,
+# 2007, 2009 Free Software Foundation, Inc.
 
 ## This program is free software; you can redistribute it and/or modify
 ## it under the terms of the GNU General Public License as published by
-## the Free Software Foundation; either version 2, or (at your option)
+## the Free Software Foundation; either version 3, or (at your option)
 ## any later version.
 
 ## This program is distributed in the hope that it will be useful,
@@ -23,26 +23,29 @@ bin_PROGRAMS = tar
 noinst_HEADERS = arith.h common.h tar.h
 tar_SOURCES = \
  buffer.c\
+ checkpoint.c\
  compare.c\
  create.c\
  delete.c\
+ exit.c\
  extract.c\
  xheader.c\
  incremen.c\
  list.c\
- mangle.c\
  misc.c\
  names.c\
  sparse.c\
+ suffix.c\
  system.c\
  tar.c\
+ transform.c\
+ unlink.c\
  update.c\
- utf8.c
+ utf8.c\
+ warning.c
 
-INCLUDES = -I$(top_srcdir)/lib -I../ -I../lib 
+INCLUDES = -I$(top_srcdir)/gnu -I../ -I../gnu -I$(top_srcdir)/lib -I../lib
 
-tar.o: ../lib/localedir.h
+LDADD = ../lib/libtar.a ../gnu/libgnu.a $(LIBINTL) $(LIBICONV)
 
-LDADD = ../lib/libtar.a $(LIBINTL) $(LIBICONV)
-
-tar_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME)
+tar_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME) $(LIB_EACCESS)
This page took 0.026078 seconds and 4 git commands to generate.