]> Dogcows Code - chaz/tar/blobdiff - src/Makefile.am
Started merging with cpio into paxutils.
[chaz/tar] / src / Makefile.am
index 0e813f3382c4e7ad2106a3c8879c87dcf3d225fa..3ba7b5cbbf6d2d73f464f5e6fc3854fb3c2d8385 100644 (file)
 ## 02111-1307, USA.
 
 bin_PROGRAMS = tar
-rmtdir=$(DEFAULT_RMT_DIR)
-rmt_PROGRAMS = @RMT@
-EXTRA_PROGRAMS = rmt
 
-noinst_HEADERS = arith.h common.h rmt.h system.h tar.h
-rmt_SOURCES = rmt.c
+noinst_HEADERS = arith.h common.h tar.h
 tar_SOURCES = \
  buffer.c\
  compare.c\
@@ -37,26 +33,16 @@ tar_SOURCES = \
  mangle.c\
  misc.c\
  names.c\
- rtapelib.c\
  sparse.c\
  system.c\
  tar.c\
  update.c\
  utf8.c
 
-localedir = $(datadir)/locale
-INCLUDES = -I$(top_srcdir)/lib -I../lib 
+INCLUDES = -I$(top_srcdir)/lib -I../ -I../lib 
 
-DISTCLEANFILES = localedir.h
-localedir.h : Makefile
-       echo '#define LOCALEDIR "$(localedir)"' >$@
-       echo "#ifndef DEFAULT_RMT_COMMAND" >> $@
-       echo "# define DEFAULT_RMT_COMMAND \"$(rmtdir)/`echo \"rmt\" | sed 's,^.*/,,;$(transform)'`$(EXEEXT)\"" >> $@
-       echo "#endif" >> $@
-
-rmt.o tar.o : localedir.h
+tar.o: ../lib/localedir.h
 
 LDADD = ../lib/libtar.a $(LIBINTL)
 
-rmt_LDADD = $(LDADD) $(LIB_SETSOCKOPT)
 tar_LDADD = $(LDADD) $(LIB_CLOCK_GETTIME)
This page took 0.022602 seconds and 4 git commands to generate.