]> Dogcows Code - chaz/tar/blobdiff - lib/Makefile.am
Migrate to Git
[chaz/tar] / lib / Makefile.am
index 466a477a7fd8ee444af72fd8d5e15ed750d69f29..fb49d43631867edd4835f1a32a9ea25d7b51ba03 100644 (file)
@@ -1,7 +1,7 @@
 # Makefile for GNU tar library.                        -*- Makefile -*-
 
 # Copyright (C) 1994, 1995, 1996, 1997, 1999, 2000, 2001, 2003, 2004,
-# 2005, 2006, 2007 Free Software Foundation, Inc.
+# 2005, 2006, 2007, 2009 Free Software Foundation, Inc.
 
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # with this program; if not, write to the Free Software Foundation, Inc.,
 # 51 Franklin St, Fifth Floor, Boston, MA  02110-1301  USA
 
-include gnulib.mk
-
+noinst_LIBRARIES=libtar.a
 rmt-command.h : Makefile
        rm -f $@-t $@
        echo "#ifndef DEFAULT_RMT_COMMAND" >> $@-t
        echo "# define DEFAULT_RMT_COMMAND \"$(DEFAULT_RMT_DIR)/`echo rmt | sed '$(transform)'`$(EXEEXT)\"" >> $@-t
        echo "#endif" >> $@-t
        mv $@-t $@
-BUILT_SOURCES += rmt-command.h
-CLEANFILES += rmt-command.h rmt-command.h-t
+BUILT_SOURCES = rmt-command.h
+CLEANFILES = rmt-command.h rmt-command.h-t
+INCLUDES = -I$(top_srcdir)/gnu -I../ -I../gnu 
 
-noinst_HEADERS += system.h system-ioctl.h rmt.h paxlib.h stdopen.h
-libtar_a_SOURCES += \
+noinst_HEADERS = system.h system-ioctl.h rmt.h paxlib.h stdopen.h
+libtar_a_SOURCES = \
   paxerror.c paxexit.c paxlib.h paxnames.c \
   prepargs.c prepargs.h \
   rtapelib.c \
@@ -37,5 +37,3 @@ libtar_a_SOURCES += \
   stdopen.c stdopen.h \
   system.h system-ioctl.h
 
-libtar_a_LIBADD += $(LIBOBJS)
-libtar_a_DEPENDENCIES += $(LIBOBJS)
This page took 0.020547 seconds and 4 git commands to generate.