]> Dogcows Code - chaz/tar/blobdiff - lib/Makefile.am
Update copyright years.
[chaz/tar] / lib / Makefile.am
index bfab8b963b67c8a79d70e75dc75c064b7e3f715c..b2971a28b55bb869a5095371a4966e19ba590d70 100644 (file)
@@ -1,45 +1,62 @@
-# Makefile for GNU tar library.
-# Copyright (C) 1994, 1995, 1996, 1997 Free Software Foundation, Inc.
+# Makefile for GNU tar library.                        -*- Makefile -*-
 
-# This program is free software; you can redistribute it and/or modify
+# Copyright 1994-1997, 1999-2001, 2003-2007, 2009-2010, 2013-2014 Free
+# Software Foundation, Inc.
+
+# This file is part of GNU tar.
+
+# GNU tar is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2, or (at your option)
-# any later version.
+# the Free Software Foundation; either version 3 of the License, or
+# (at your option) any later version.
 
-# This program is distributed in the hope that it will be useful,
+# GNU tar is distributed in the hope that it will be useful,
 # but WITHOUT ANY WARRANTY; without even the implied warranty of
 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
 # GNU General Public License for more details.
 
 # You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA
-# 02111-1307, USA.
-
-AUTOMAKE_OPTIONS = gnits
-
-noinst_LIBRARIES = libtar.a
-
-EXTRA_DIST = \
-alloca.c fileblocks.c fnmatch.c ftruncate.c execlp.c gmalloc.c \
-memset.c mkdir.c modechange.h rename.c rmdir.c stpcpy.c strstr.c
+# along with this program.  If not, see <http://www.gnu.org/licenses/>.
+
+noinst_LIBRARIES=libtar.a
+rmt-command.h : Makefile
+       $(AM_V_GEN)rm -f $@-t $@
+       $(AM_V_at)echo "#ifndef DEFAULT_RMT_COMMAND" >> $@-t
+       $(AM_V_at)echo "# define DEFAULT_RMT_COMMAND \"$(DEFAULT_RMT_DIR)/`echo rmt | sed '$(transform)'`$(EXEEXT)\"" >> $@-t
+       $(AM_V_at)echo "#endif" >> $@-t
+       $(AM_V_at)mv $@-t $@
+BUILT_SOURCES = rmt-command.h
+CLEANFILES = rmt-command.h rmt-command.h-t
+AM_CPPFLAGS = -I$(top_srcdir)/gnu -I../ -I../gnu
+AM_CFLAGS = $(GNULIB_WARN_CFLAGS) $(WERROR_CFLAGS)
 
 noinst_HEADERS = \
-argmatch.h backupfile.h error.h fnmatch.h getopt.h getdate.h getpagesize.h \
-pathmax.h
+ paxlib.h\
+ rmt.h\
+ stdopen.h\
+ system.h\
+ system-ioctl.h\
+ wordsplit.h\
+ xattr-at.h
 
 libtar_a_SOURCES = \
-argmatch.c backupfile.c error.c getdate.y getopt.c getopt1.c getversion.c \
-modechange.c msleep.c xgetcwd.c xmalloc.c xstrdup.c
-
-INCLUDES = -I.. -I$(srcdir) -I../intl
-
-libtar_a_LIBADD = @ALLOCA@ @LIBOBJS@
-libtar_a_DEPENDENCIES = $(libtar_a_LIBADD)
-
-# Say $(srcdir), so GNU make does not report an ambiguity with the .y.c rule.
-$(srcdir)/getdate.c: getdate.y
-       @echo Expect 13 shift/reduce conflicts...
-       cd $(srcdir) && \
-         $(YACC) $(YFLAGS) getdate.y; \
-         mv -f y.tab.c getdate.c
+  paxerror.c paxexit-status.c paxlib.h paxnames.c \
+  prepargs.c prepargs.h \
+  rtapelib.c \
+  rmt.h \
+  stdopen.c stdopen.h \
+  system.h system-ioctl.h \
+  wordsplit.c\
+  xattr-at.c
+
+if !TAR_COND_XATTR_H
+BUILT_SOURCES += attr/xattr.h
+attr/xattr.h: attr-xattr.in.h $(top_builddir)/config.status
+       $(AM_V_at)$(MKDIR_P) attr
+       $(AM_V_GEN)rm -f $@-t $@ && \
+        cp $(srcdir)/attr-xattr.in.h attr/xattr.h
+endif
+
+MOSTLYCLEANFILES = attr/xattr.h
+
+EXTRA_DIST = attr-xattr.in.h
This page took 0.022482 seconds and 4 git commands to generate.