add missing dependencies; all up-to-date now
[chaz/chatty] / Makefile.PL
1 #!/usr/bin/env perl
2 # IMPORTANT: if you delete this file your app will not work as
3 # expected. You have been warned.
4 use inc::Module::Install;
5 use Module::Install::Catalyst; # Complain loudly if you don't have
6 # Catalyst::Devel installed or haven't said
7 # 'make dist' to create a standalone tarball.
8
9 name 'Chatty';
10 all_from 'lib/Chatty.pm';
11
12 requires 'Catalyst::Runtime' => '5.90007';
13 requires 'Catalyst::Authentication::Realm::SimpleDB';
14 requires 'Catalyst::Model::DBIC::Schema';
15 requires 'Catalyst::Plugin::ConfigLoader';
16 requires 'Catalyst::Plugin::StackTrace';
17 requires 'Catalyst::Plugin::Static::Simple';
18 requires 'Catalyst::Plugin::Authentication';
19 requires 'Catalyst::Plugin::Session';
20 requires 'Catalyst::Plugin::Session::Store::FastMmap';
21 requires 'Catalyst::Plugin::Session::State::Cookie';
22 requires 'Catalyst::Plugin::Unicode::Encoding';
23 requires 'Catalyst::Action::RenderView';
24 requires 'Catalyst::View::JSON';
25 requires 'Catalyst::View::TT';
26 requires 'HTML::FormHandler';
27 requires 'HTML::FormHandler::Model::DBIC';
28 requires 'JSON::XS';
29 requires 'Moose';
30 requires 'MooseX::MarkAsMethods';
31 requires 'MooseX::NonMoose';
32 requires 'namespace::autoclean';
33 requires 'Config::General'; # This should reflect the config file format you've chosen
34 # See Catalyst::Plugin::ConfigLoader for supported formats
35 test_requires 'Test::More' => '0.88';
36 catalyst;
37
38 # Add targets to run the developer server.
39 sub MY::postamble {
40 return <<END;
41 run: all
42 ./script/chatty_server.pl -r
43 debug: all
44 ./script/chatty_server.pl -r -d
45 END
46 }
47
48 install_script glob('script/*.pl');
49 auto_install;
50 WriteAll;
This page took 0.038193 seconds and 4 git commands to generate.