]> Dogcows Code - chaz/tint2/blobdiff - src/tint2conf/CMakeLists.txt
start tint2conf work
[chaz/tint2] / src / tint2conf / CMakeLists.txt
index 76f8069fe6ab4b640853e8e80f74ee59cfd2d78b..5526c7d5e7626fc830a53e380c2cc7a52fd1bc6c 100644 (file)
@@ -20,6 +20,7 @@ include_directories( ../util
 set(SOURCES ../util/common.c
             main.c
             properties.c
+            properties_rw.c
             theme_view.c )
 link_directories( ${X11_T2C_LIBRARY_DIRS}
                   ${GLIB2_LIBRARY_DIRS}
@@ -45,6 +46,6 @@ set_target_properties( tint2conf PROPERTIES LINK_FLAGS "-pthread" )
 
 install( TARGETS tint2conf DESTINATION bin )
 install( PROGRAMS tintwizard.py DESTINATION bin )
-install( FILES taskbar.svg DESTINATION share/icons/hicolor/scalable/apps )
-install( FILES tint2conf.desktop DESTINATION share/applications )
+install( FILES taskbar.svg DESTINATION ${DATADIR}/icons/hicolor/scalable/apps )
+install( FILES tint2conf.desktop DESTINATION ${DATADIR}/applications )
 install( CODE "execute_process(COMMAND gtk-update-icon-cache -f -t ${DATADIR}/icons/hicolor WORKING_DIRECTORY ${CMAKE_INSTALL_PREFIX})" )
This page took 0.023153 seconds and 4 git commands to generate.