]> Dogcows Code - chaz/p5-CGI-Ex/blob - CGI-Ex.spec
95d516b93035a76ddc9332ddb7bdf7e011ad0ce7
[chaz/p5-CGI-Ex] / CGI-Ex.spec
1 %define name CGI-Ex
2 %define version 1.14
3
4 %define __find_provides %( echo -n /usr/lib/rpm/find-provides && [ -x /usr/lib/rpm/find-provides.perl ] && echo .perl )
5 %define __find_requires %( echo -n /usr/lib/rpm/find-requires && [ -x /usr/lib/rpm/find-requires.perl ] && echo .perl )
6
7 Summary: @SUMMARY@
8 Name: %{name}
9 Version: %{version}
10 Release: 1
11 Source0: http://seamons.com/cgi_ex/%{name}-%{version}.tar.gz
12 Group: Development/Perl
13 License: Perl Artistic
14 Vendor: Paul Seamons
15 Packager: Paul Seamons
16 BuildRequires: perl
17 BuildArch: noarch
18 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
19 Provides: %{name} = %{version}
20
21 %description
22 CGI::Ex is a Perl module that offers an extended suite of
23 functionality, over and above that offered by CGI, HTML::FillInForm,
24 and the host of Validator scripts on CPAN. CGI::Ex tries to use the
25 best functions from existing modules and extend them with rich
26 functionality. Particularly of interest is CGI::Ex::App which
27 provides extremely easy yet robust CGI developement.
28
29 %prep
30 %setup -q -n %{name}-%{version}
31
32 %build
33 %{__perl} Makefile.PL
34 %{__make} OPTIMIZE="$RPM_OPT_FLAGS"
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38
39 # do the build
40 %{makeinstall} PREFIX=$RPM_BUILD_ROOT%{_prefix}
41 #if [ -x /usr/lib/rpm/brp-mandrake ] ; then
42 # /usr/lib/rpm/brp-mandrake
43 #elif [ -x /usr/lib/brp-compress ] ; then
44 # /usr/lib/rpm/brp-compress
45 #fi
46
47 # Clean up some files we don't want/need
48 find $RPM_BUILD_ROOT%{_prefix} -type d | tac | xargs rmdir --ign
49 find $RPM_BUILD_ROOT%{_prefix} | grep i386 | tac | xargs rm -rf
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53 HERE=`pwd`
54 cd ..
55 rm -rf $HERE
56
57 %files
58 %defattr(-,root,root)
59 #%doc README Changes
60 %{_prefix}
61
62 %changelog
63 * Sat Nov 11 2003 Paul Seamons <>
64 - first try
This page took 0.030551 seconds and 3 git commands to generate.