]> Dogcows Code - chaz/p5-CGI-Ex/blob - CGI-Ex.spec
CGI::Ex 2.04
[chaz/p5-CGI-Ex] / CGI-Ex.spec
1 %define name CGI-Ex
2 %define version 2.03
3
4 %define __find_provides %( echo -n /usr/lib/rpm/find-provides && [ -x /usr/lib/rpm/find-provides.perl ] && echo .perl )
5 %define __find_requires %( echo -n /usr/lib/rpm/find-requires && [ -x /usr/lib/rpm/find-requires.perl ] && echo .perl )
6
7 Summary: @SUMMARY@
8 Name: %{name}
9 Version: %{version}
10 Release: 1
11 Source0: http://seamons.com/cgi_ex/%{name}-%{version}.tar.gz
12 Group: Development/Perl
13 License: Perl Artistic
14 Vendor: Paul Seamons
15 Packager: Paul Seamons
16 BuildRequires: perl
17 BuildArch: noarch
18 BuildRoot: %{_tmppath}/%{name}-%{version}-buildroot
19 Provides: %{name} = %{version}
20
21 %description
22 CGI::Ex provides a suite of utilities to make writing CGI scripts
23 more enjoyable. Although they can all be used separately, the
24 main functionality of each of the modules is best represented in
25 the CGI::Ex::App module. CGI::Ex::App takes CGI application building
26 to the next step. CGI::Ex::App is not quite a framework (which normally
27 includes prebuilt html) instead CGI::Ex::App is an extended application
28 flow that dramatically reduces CGI build time in most cases. It does so
29 using as little magic as possible. See L<CGI::Ex::App>.
30
31 The main functionality is provided by several other modules that
32 may be used separately, or together through the CGI::Ex interface.
33
34 %prep
35 %setup -q -n %{name}-%{version}
36
37 %build
38 %{__perl} Makefile.PL
39 %{__make} OPTIMIZE="$RPM_OPT_FLAGS"
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43
44 # do the build
45 %{makeinstall} PREFIX=$RPM_BUILD_ROOT%{_prefix}
46 #if [ -x /usr/lib/rpm/brp-mandrake ] ; then
47 # /usr/lib/rpm/brp-mandrake
48 #elif [ -x /usr/lib/brp-compress ] ; then
49 # /usr/lib/rpm/brp-compress
50 #fi
51
52 # Clean up some files we don't want/need
53 find $RPM_BUILD_ROOT%{_prefix} -type d | tac | xargs rmdir --ign
54 find $RPM_BUILD_ROOT%{_prefix} | grep i386 | tac | xargs rm -rf
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58 HERE=`pwd`
59 cd ..
60 rm -rf $HERE
61
62 %files
63 %defattr(-,root,root)
64 #%doc README Changes
65 %{_prefix}
66
67 %changelog
68 * Sat Nov 11 2003 Paul Seamons <>
69 - first try
This page took 0.031613 seconds and 4 git commands to generate.