]> Dogcows Code - chaz/homebank/blobdiff - src/Makefile.am
Merge branch 'upstream'
[chaz/homebank] / src / Makefile.am
index 4115add2ba511449e529e3d53f04a9161f664ffc..9e4fd20426d55c6f41e1d895f77f79f3822e0e2e 100644 (file)
@@ -14,13 +14,17 @@ USER_INTERFACE =
        
 
 homebank_SOURCES =  \
-       dsp_account.c \
-       dsp_account.h \
-       dsp_mainwindow.c \
-       dsp_mainwindow.h \
+       dsp-account.c \
+       dsp-account.h \
+       dsp-mainwindow.c \
+       dsp-mainwindow.h \
        enums.h \
        gtk-chart.c \
        gtk-chart.h \
+       gtk-chart-colors.c \
+       gtk-chart-colors.h \
+       gtk-chart-progress.c \
+       gtk-chart-progress.h \
        gtk-dateentry.c \
        gtk-dateentry.h \
        hb-account.c \
@@ -31,6 +35,8 @@ homebank_SOURCES =  \
        hb-assign.h \
        hb-category.c \
        hb-category.h \
+       hb-currency.c \
+       hb-currency.h \
        hb-encoding.c \
        hb-encoding.h \
        hb-export.c \
@@ -41,6 +47,9 @@ homebank_SOURCES =  \
        hb-hbfile.h \
        hb-import.c \
        hb-import.h \
+       hb-import-ofx.c \
+       hb-import-qif.c \
+       hb-import-csv.c \
        hb-misc.c \
        hb-misc.h \
        hb-payee.c \
@@ -51,48 +60,56 @@ homebank_SOURCES =  \
        hb-report.h \
        hb-tag.c \
        hb-tag.h \
+       hb-split.c \
+       hb-split.h \
        hb-transaction.c \
        hb-transaction.h \
        hb-xml.c \
        hb-xml.h \
        homebank.c \
        homebank.h \
-       imp_qif.c \
-       imp_qif.h \
-       import.c \
-       import.h \
+       hub-account.c \
+       hub-account.h \
+       hub-scheduled.c \
+       hub-scheduled.h \
+       hub-spending.c \
+       hub-spending.h \
+       hub-transaction.c \
+       hub-transaction.h \
        language.c \
        language.h \
-       list_account.c \
-       list_account.h \
-       list_operation.c \
-       list_operation.h \
-       list_topspending.c \
-       list_topspending.h \
-       list_upcoming.c \
-       list_upcoming.h \
-       rep_balance.c \
-       rep_balance.h \
-       rep_budget.c \
-       rep_budget.h \
-       rep_stats.c \
-       rep_stats.h \
-       rep_time.c \
-       rep_time.h \
-       rep_vehicle.c \
-       rep_vehicle.h \
+       list-account.c \
+       list-account.h \
+       list-operation.c \
+       list-operation.h \
+       list-scheduled.c \
+       list-scheduled.h \
+       rep-balance.c \
+       rep-balance.h \
+       rep-budget.c \
+       rep-budget.h \
+       rep-stats.c \
+       rep-stats.h \
+       rep-time.c \
+       rep-time.h \
+       rep-vehicle.c \
+       rep-vehicle.h \
        ui-account.c \
        ui-account.h \
        ui-archive.c \
        ui-archive.h \
        ui-assign.c \
        ui-assign.h \
+       ui-assist-import.c \
+       ui-assist-import.h \
        ui-assist-start.c \
        ui-assist-start.h \
        ui-budget.c \
        ui-budget.h \
        ui-category.c \
        ui-category.h \
+       ui-currency.c \
+       ui-currency.h \
        ui-dialogs.c \
        ui-dialogs.h \
        ui-filter.c \
@@ -103,16 +120,24 @@ homebank_SOURCES =  \
        ui-payee.h \
        ui-pref.c \
        ui-pref.h \
+       ui-split.c \
+       ui-split.h \
+       ui-tag.c \
+       ui-tag.h \
        ui-transaction.c \
        ui-transaction.h \
+       ui-txn-multi.c \
+       ui-txn-multi.h \
+       ui-widgets-data.c \
        ui-widgets.c \
-       ui-widgets.h \
-       gtk-chart-colors.c \
-       gtk-chart-colors.h 
+       ui-widgets.h
+
 
-homebank_LDADD = $(DEPS_LIBS)
+homebank_LDADD = $(DEPS_LIBS) \
+       $(LIBSOUP_LIBS)
 
 AM_CPPFLAGS = \
        $(DEPS_CFLAGS) \
+       $(LIBSOUP_CFLAGS) \
        $(common_defines)
 
This page took 0.019004 seconds and 4 git commands to generate.