]> Dogcows Code - chaz/homebank/blobdiff - src/Makefile.am
Merge branch 'master' into ext-perl
[chaz/homebank] / src / Makefile.am
index 71c57f193b249e9e6bf3cf952f3539645e6ddad2..484ce27b8a65ad79127df95daac4335f1d554c32 100644 (file)
@@ -22,6 +22,10 @@ homebank_SOURCES =  \
        enums.h \
        gtk-chart.c \
        gtk-chart.h \
+       gtk-chart-colors.c \
+       gtk-chart-colors.h \
+       gtk-chart-stack.c \
+       gtk-chart-stack.h \
        gtk-dateentry.c \
        gtk-dateentry.h \
        hb-account.c \
@@ -32,6 +36,8 @@ homebank_SOURCES =  \
        hb-assign.h \
        hb-category.c \
        hb-category.h \
+       hb-currency.c \
+       hb-currency.h \
        hb-encoding.c \
        hb-encoding.h \
        hb-export.c \
@@ -42,6 +48,9 @@ homebank_SOURCES =  \
        hb-hbfile.h \
        hb-import.c \
        hb-import.h \
+       hb-import-ofx.c \
+       hb-import-qif.c \
+       hb-import-csv.c \
        hb-misc.c \
        hb-misc.h \
        hb-payee.c \
@@ -52,16 +61,14 @@ homebank_SOURCES =  \
        hb-report.h \
        hb-tag.c \
        hb-tag.h \
+       hb-split.c \
+       hb-split.h \
        hb-transaction.c \
        hb-transaction.h \
        hb-xml.c \
        hb-xml.h \
        homebank.c \
        homebank.h \
-       imp_qif.c \
-       imp_qif.h \
-       import.c \
-       import.h \
        language.c \
        language.h \
        list_account.c \
@@ -88,12 +95,16 @@ homebank_SOURCES =  \
        ui-archive.h \
        ui-assign.c \
        ui-assign.h \
+       ui-assist-import.c \
+       ui-assist-import.h \
        ui-assist-start.c \
        ui-assist-start.h \
        ui-budget.c \
        ui-budget.h \
        ui-category.c \
        ui-category.h \
+       ui-currency.c \
+       ui-currency.h \
        ui-dialogs.c \
        ui-dialogs.h \
        ui-filter.c \
@@ -104,12 +115,12 @@ homebank_SOURCES =  \
        ui-payee.h \
        ui-pref.c \
        ui-pref.h \
+       ui-split.c \
+       ui-split.h \
        ui-transaction.c \
        ui-transaction.h \
        ui-widgets.c \
        ui-widgets.h \
-       gtk-chart-colors.c \
-       gtk-chart-colors.h \
        refcount.h \
        ext.c \
        ext.h \
@@ -120,10 +131,13 @@ homebank_SOURCES =  \
 
 EXTRA_homebank_DEPENDENCIES = $(PERL_OBJS)
 
-homebank_LDADD = $(PERL_OBJS) $(DEPS_LIBS)
+homebank_LDADD = $(DEPS_LIBS) \
+       $(LIBSOUP_LIBS) \
+       $(PERL_OBJS)
 
 AM_CPPFLAGS = \
        $(DEPS_CFLAGS) \
+       $(LIBSOUP_CFLAGS) \
        $(common_defines)
 
 $(PERL_OBJS): CPPFLAGS += $(PERL_CPPFLAGS)
This page took 0.024273 seconds and 4 git commands to generate.