]> Dogcows Code - chaz/homebank/blobdiff - src/Makefile.am
Merge branch 'master' into ext-perl
[chaz/homebank] / src / Makefile.am
index 9c7e1936cc8bd4f298b0309c35ef48339f75ffb8..20da8f18246114c77313051187aa34980ea3da4f 100644 (file)
@@ -1,7 +1,8 @@
 
 common_defines = \
        -DSHARE_DIR=\""$(pkgdatadir)"\" \
-       -DDATA_DIR=\""$(datadir)"\"
+       -DDATA_DIR=\""$(datadir)"\" \
+       -DPKGLIB_DIR=\""$(pkglibdir)"\"
 
 
 bin_PROGRAMS = homebank
@@ -121,13 +122,36 @@ homebank_SOURCES =  \
        ui-txn-multi.c \
        ui-txn-multi.h \
        ui-widgets.c \
-       ui-widgets.h
+       ui-widgets.h \
+       refcount.h \
+       ext.c \
+       ext.h \
+       ext-value.c \
+       ext-value.h \
+       ext-native.c \
+       ext-perl.xs
+
+EXTRA_homebank_DEPENDENCIES = $(PERL_OBJS)
 
 homebank_LDADD = $(DEPS_LIBS) \
-       $(LIBSOUP_LIBS)
+       $(LIBSOUP_LIBS) \
+       $(PERL_OBJS)
 
 AM_CPPFLAGS = \
        $(DEPS_CFLAGS) \
        $(LIBSOUP_CFLAGS) \
        $(common_defines)
 
+$(PERL_OBJS): CPPFLAGS += $(PERL_CPPFLAGS)
+
+ext-perl.c: ext-perl.xs typemap
+       $(XSUBPP) -typemap $(PERL_PRIVLIBEXP)/ExtUtils/typemap -typemap typemap $< >$@
+
+perlxsi.c: Makefile
+       $(PERL) -MExtUtils::Embed -e xsinit -- -std HomeBank
+
+CLEANFILES = ext-perl.c perlxsi.c
+
+pluginsupportdir = $(pkglibdir)
+pluginsupport_DATA = HomeBank.pm
+
This page took 0.022171 seconds and 4 git commands to generate.