]> Dogcows Code - chaz/openbox/blobdiff - openbox/Makefile.am
prepare for alpha1 release.
[chaz/openbox] / openbox / Makefile.am
index adc06bf8f2cf464e89179a5db443fca75249c20c..8e5144ab864301d947e69af0ece28732ef7ff464 100644 (file)
@@ -6,38 +6,81 @@ desktopfilesdir=$(datadir)/gnome/wm-properties
 binary=openbox
 url=http://openbox.org/
 
-CPPFLAGS=$(X_CFLAGS) $(SM_CFLAGS) $(XFT_CFLAGS) $(GLIB_CFLAGS) \
-         $(GMODULE_CFLAGS) $(LIBSN_CFLAGS) $(GL_CFLAGS) $(XML_CFLAGS) \
-         @CPPFLAGS@ \
-         -DLOCALEDIR=\"$(localedir)\" \
-         -DPLUGINDIR=\"$(plugindir)\" \
-         -DRCDIR=\"$(rcdir)\" \
-         -DG_LOG_DOMAIN=\"Openbox\" \
-         -DBINARY=\"$(binary)\"
+AM_CPPFLAGS=$(X_CFLAGS) $(SM_CFLAGS) $(XFT_CFLAGS) $(GLIB_CFLAGS) \
+            $(GMODULE_CFLAGS) $(LIBSN_CFLAGS) $(GL_CFLAGS) $(XML_CFLAGS) \
+            -DLOCALEDIR=\"$(localedir)\" \
+            -DPLUGINDIR=\"$(plugindir)\" \
+            -DRCDIR=\"$(rcdir)\" \
+            -DG_LOG_DOMAIN=\"Openbox\" \
+            -DBINARY=\"$(binary)\"
 
 INCLUDES=-I..
 LIBS=$(X_LIBS) $(SM_LIBS) $(XFT_LIBS) $(XINERAMA_LIBS) $(XKB_LIBS) \
        $(XRANDR_LIBS) $(VIDMODE_LIBS) $(XSHAPE_LIBS) $(GLIB_LIBS) \
-       $(GMODULE_LIBS) $(LIBSN_LIBS) $(XML_LIBS) @LIBS@ @LIBINTL@
+       $(GMODULE_LIBS) $(LIBSN_LIBS) $(XML_LIBS) $(EFENCE_LIBS) \
+       @LIBS@ @LIBINTL@
 
 bin_PROGRAMS=$(binary)
 
 openbox_LDADD=-lobrender -L../render -lobparser -L../parser
 openbox_LDFLAGS=-export-dynamic
-openbox_SOURCES=action.c client.c config.c \
-                extensions.c focus.c frame.c grab.c menu.c menu_render.c \
-                openbox.c framerender.c plugin.c prop.c screen.c \
-                stacking.c dispatch.c event.c group.c timer.c xerror.c \
-                moveresize.c startup.c popup.c dock.c window.c
-
-noinst_HEADERS=action.h client.h config.h dispatch.h event.h extensions.h \
-               focus.h frame.h framerender.h geom.h gettext.h grab.h group.h \
-               menu.h openbox.h plugin.h prop.h screen.h \
-               stacking.h timer.h xerror.h moveresize.h startup.h popup.h \
-               dock.h window.h
+openbox_SOURCES=\
+  action.h \
+  action.c \
+  client.h \
+  client.c \
+  config.h \
+  config.c \
+  extensions.h \
+  extensions.c \
+  focus.h \
+  focus.c \
+  frame.h \
+  frame.c \
+  grab.h \
+  grab.c \
+  menu.h \
+  menu.c \
+  menu_render.c \
+  openbox.h \
+  openbox.c \
+  framerender.h \
+  framerender.c \
+  plugin.h \
+  plugin.c \
+  prop.h \
+  prop.c \
+  screen.h \
+  screen.c \
+  stacking.h \
+  stacking.c \
+  dispatch.h \
+  dispatch.c \
+  event.h \
+  event.c \
+  group.h \
+  group.c \
+  timer.h \
+  timer.c \
+  xerror.h \
+  xerror.c \
+  moveresize.h \
+  moveresize.c \
+  startup.h \
+  startup.c \
+  popup.h \
+  popup.c \
+  dock.h \
+  dock.c \
+  window.h \
+  window.c \
+  gettext.h \
+  geom.h
 
 desktopfiles_DATA=openbox.desktop
 
+EXTRA_DIST=$(desktopfiles_DATA)
+
 MAINTAINERCLEANFILES=Makefile.in
 
 distclean-local:
This page took 0.024066 seconds and 4 git commands to generate.