]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
more normal configure options for gtk and qt4
[chaz/yoink] / src / Makefile.am
index 98cf9b91e804e3ae52377c093b9a13719352fa8c..fa6c9814273a2e3e3adc62eacae71a6a217637b0 100644 (file)
@@ -114,21 +114,25 @@ yoink_SOURCES = \
                                $(ENDLIST)
 
 if WIN32
-
 yoink_SOURCES += yoink.rc
-
 .rc.o:
        $(WINDRES) -o $@ -i $<
-
 else
-
 YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
-
 run: all
        $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
+endif
+
+if LINK_SH
+yoink$(EXEEXT): $(yoink_OBJECTS) $(yoink_DEPENDENCIES)
+       @rm -f yoink$(EXEEXT)
+       @LINK="$(CXXLINK) $(yoink_OBJECTS) $(yoink_LDADD) $(LIBS)"\
+               sh $(top_srcdir)/link.sh
 
+clean-local:
+       rm -f .link/*
 endif
 
This page took 0.017459 seconds and 4 git commands to generate.