]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
improved man page
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..f10027266a2e646c2b5f7cc5f3b97f6662af6474 100644 (file)
@@ -1,6 +1,127 @@
 
+#
+# Yoink
+# Process this file with automake to produce a Makefile.
+#
+
+
+#
+# libmoof.a
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+noinst_LIBRARIES = libmoof.a
+
+libmoof_a_SOURCES = \
+                                       Moof/Aabb.cc \
+                                       Moof/Aabb.hh \
+                                       Moof/Camera.cc \
+                                       Moof/Camera.hh \
+                                       Moof/ConvertUTF.c \
+                                       Moof/ConvertUTF.h \
+                                       Moof/Cullable.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
+                                       Moof/Drawable.hh \
+                                       Moof/Engine.cc \
+                                       Moof/Engine.hh \
+                                       Moof/Entity.hh \
+                                       Moof/Event.hh \
+                                       Moof/Exception.hh \
+                                       Moof/Frustum.cc \
+                                       Moof/Frustum.hh \
+                                       Moof/Hash.cc \
+                                       Moof/Hash.hh \
+                                       Moof/Interpolator.hh \
+                                       Moof/Layer.hh \
+                                       Moof/Library.hh \
+                                       Moof/Log.cc \
+                                       Moof/Log.hh \
+                                       Moof/Math.hh \
+                                       Moof/ModalDialog.hh \
+                                       Moof/Octree.hh \
+                                       Moof/OpenGL.hh \
+                                       Moof/Plane.cc \
+                                       Moof/Plane.hh \
+                                       Moof/Rectangle.cc \
+                                       Moof/Rectangle.hh \
+                                       Moof/Resource.cc \
+                                       Moof/Resource.hh \
+                                       Moof/RigidBody.hh \
+                                       Moof/Script.hh \
+                                       Moof/Settings.cc \
+                                       Moof/Settings.hh \
+                                       Moof/Sound.cc \
+                                       Moof/Sound.hh \
+                                       Moof/Sphere.cc \
+                                       Moof/Sphere.hh \
+                                       Moof/StringTools.cc \
+                                       Moof/StringTools.hh \
+                                       Moof/Texture.cc \
+                                       Moof/Texture.hh \
+                                       Moof/Thread.hh \
+                                       Moof/Timer.cc \
+                                       Moof/Timer.hh \
+                                       Moof/Transition.hh \
+                                       Moof/Video.cc \
+                                       Moof/Video.hh \
+                                       Moof/fastevents.c \
+                                       Moof/fastevents.h \
+                                       $(ENDLIST)
+
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
+
+EXTRA_DIST = Moof/cml Moof/stlplus
+
+
+#
+# yoink
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
 bin_PROGRAMS = yoink
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+yoink_SOURCES = \
+                               Animation.cc \
+                               Animation.hh \
+                               Character.cc \
+                               Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
+                               GameLayer.cc \
+                               GameLayer.hh \
+                               Heroine.cc \
+                               Heroine.hh \
+                               Hud.cc \
+                               Hud.hh \
+                               MainLayer.cc \
+                               MainLayer.hh \
+                               Scene.cc \
+                               Scene.hh \
+                               Tilemap.cc \
+                               Tilemap.hh \
+                               TilemapFont.cc \
+                               TilemapFont.hh \
+                               TitleLayer.cc \
+                               TitleLayer.hh \
+                               Typesetter.cc \
+                               Typesetter.hh \
+                               version.h \
+                               $(ENDLIST)
+
+if WIN32
+yoink_SOURCES += yoink.rc yoink.ico
+.rc.o:
+       @WINDRES@ -o $@ -i $<
+endif
+
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD = libmoof.a
+
+
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
+
+run: all
+       $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
+
+debug: all
+       $(YOINK_ENVIRONMENT) gdb ./yoink
 
This page took 0.01928 seconds and 4 git commands to generate.