]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
scene drawing correctly implemented; new classes
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..ea68cde7fef42b8edc6039787f56204e067e5c16 100644 (file)
@@ -1,6 +1,92 @@
 
-bin_PROGRAMS = yoink
+noinst_LTLIBRARIES = libmoof.la
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+libmoof_la_SOURCES = \
+                                  Moof/Aabb.cc \
+                                  Moof/Aabb.hh \
+                                  Moof/Animation.cc \
+                                  Moof/Animation.hh \
+                                  Moof/Camera.cc \
+                                  Moof/Camera.hh \
+                                  Moof/ConvertUTF.c \
+                                  Moof/ConvertUTF.h \
+                                  Moof/Cullable.hh \
+                                  Moof/Deserializer.cc \
+                                  Moof/Deserializer.hh \
+                                  Moof/Dispatcher.cc \
+                                  Moof/Dispatcher.hh \
+                                  Moof/Drawable.hh \
+                                  Moof/Engine.cc \
+                                  Moof/Engine.hh \
+                                  Moof/Entity.hh \
+                                  Moof/Event.hh \
+                                  Moof/Frustum.hh \
+                                  Moof/Interpolator.hh \
+                                  Moof/Math.hh \
+                                  Moof/Mippleton.hh \
+                                  Moof/Octree.hh \
+                                  Moof/OpenGL.cc \
+                                  Moof/OpenGL.hh \
+                                  Moof/Plane.hh \
+                                  Moof/Profiler.hh \
+                                  Moof/Random.cc \
+                                  Moof/Random.hh \
+                                  Moof/Resource.cc \
+                                  Moof/Resource.hh \
+                                  Moof/Scene.cc \
+                                  Moof/Scene.hh \
+                                  Moof/Serializable.cc \
+                                  Moof/Serializable.hh \
+                                  Moof/Serializer.cc \
+                                  Moof/Serializer.hh \
+                                  Moof/Settings.cc \
+                                  Moof/Settings.hh \
+                                  Moof/Singleton.hh \
+                                  Moof/StringTools.cc \
+                                  Moof/StringTools.hh \
+                                  Moof/Texture.cc \
+                                  Moof/Texture.hh \
+                                  Moof/Thread.hh \
+                                  Moof/Tilemap.cc \
+                                  Moof/Tilemap.hh \
+                                  Moof/Timer.cc \
+                                  Moof/Timer.hh \
+                                  Moof/Tree.hh \
+                                  Moof/Video.cc \
+                                  Moof/Video.hh \
+                                  Moof/fastevents.c \
+                                  Moof/fastevents.h \
+                                  $(ENDLIST)
+
+libmoof_la_CPPFLAGS = -I$(top_srcdir)/src/Moof -I$(top_srcdir)/yajl/src
+libmoof_la_LIBADD   = $(top_srcdir)/yajl/libyajl.la
+
+
+bin_PROGRAMS   = yoink
+
+yoink_SOURCES  = \
+                                Character.cc \
+                                Character.hh \
+                                TilemapFont.cc \
+                                TilemapFont.hh \
+                                Typesetter.cc \
+                                Typesetter.hh \
+                                YoinkApp.cc \
+                                YoinkApp.hh \
+                                $(ENDLIST)
+
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD    = libmoof.la
+
+
+EXTRA_DIST = Moof/cml
+
+
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
+
+run: all
+       $(YOINK_ENVIRONMENT) ./yoink
+
+debug: all
+       $(YOINK_ENVIRONMENT) gdb ./yoink
 
This page took 0.019506 seconds and 4 git commands to generate.