]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
packet copy bugfix
[chaz/yoink] / src / Makefile.am
index a7598d40e740b65482534a8c936e59edd1cfd2e3..c9b5dd9bfe79714b2287628b435b4cc128f94a89 100644 (file)
@@ -7,53 +7,62 @@
 
 #
 # libmoof.a
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 noinst_LIBRARIES = libmoof.a
 
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
+
 libmoof_a_SOURCES = \
                                        Moof/Aabb.cc \
                                        Moof/Aabb.hh \
+                                       Moof/Backend.cc \
+                                       Moof/Backend.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
+                                       Moof/Contact.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
                                        Moof/Cullable.hh \
-                                       Moof/Dispatcher.cc \
-                                       Moof/Dispatcher.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
-                                       Moof/Engine.cc \
-                                       Moof/Engine.hh \
                                        Moof/Entity.hh \
+                                       Moof/Error.hh \
                                        Moof/Event.hh \
-                                       Moof/Exception.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
-                                       Moof/Hash.cc \
-                                       Moof/Hash.hh \
+                                       Moof/HashTools.cc \
+                                       Moof/HashTools.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
                                        Moof/Interpolator.hh \
-                                       Moof/Layer.hh \
+                                       Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
+                                       Moof/Manager.hh \
                                        Moof/Math.hh \
-                                       Moof/Mippleton.hh \
+                                       Moof/ModalDialog.hh \
+                                       Moof/Network.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
+                                       Moof/Packet.cc \
+                                       Moof/Packet.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
-                                       Moof/Random.cc \
-                                       Moof/Random.hh \
-                                       Moof/Rectangle.cc \
-                                       Moof/Rectangle.hh \
+                                       Moof/Ray.hh \
                                        Moof/Resource.cc \
                                        Moof/Resource.hh \
-                                       Moof/RK4.hh \
+                                       Moof/RigidBody.hh \
                                        Moof/Script.hh \
+                                       Moof/Service.cc \
+                                       Moof/Service.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
+                                       Moof/Shape.hh \
+                                       Moof/Socket.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
-                                       Moof/Sphere.cc \
                                        Moof/Sphere.hh \
                                        Moof/StringTools.cc \
                                        Moof/StringTools.hh \
@@ -62,64 +71,74 @@ libmoof_a_SOURCES = \
                                        Moof/Thread.hh \
                                        Moof/Timer.cc \
                                        Moof/Timer.hh \
-                                       Moof/Transition.hh \
                                        Moof/Video.cc \
                                        Moof/Video.hh \
+                                       Moof/View.cc \
+                                       Moof/View.hh \
                                        Moof/fastevents.c \
                                        Moof/fastevents.h \
                                        $(ENDLIST)
 
-libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
-
 EXTRA_DIST = Moof/cml Moof/stlplus
 
 
 #
 # yoink
-#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
 bin_PROGRAMS = yoink
 
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD = libmoof.a
+
 yoink_SOURCES = \
                                Animation.cc \
                                Animation.hh \
                                Character.cc \
                                Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
+                               GameState.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
                                Hud.hh \
-                               MainLayer.cc \
-                               MainLayer.hh \
+                               Main.cc \
+                               Main.hh \
                                Scene.cc \
                                Scene.hh \
-                               Tilemap.cc \
-                               Tilemap.hh \
                                TilemapFont.cc \
                                TilemapFont.hh \
                                TitleLayer.cc \
                                TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
+                               version.c \
+                               version.h \
                                $(ENDLIST)
 
 if WIN32
-yoink_SOURCES += yoink.rc yoink.ico
+yoink_SOURCES += yoink.rc
 .rc.o:
-       @WINDRES@ -o $@ -i $<
-endif
-
-yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
-yoink_LDADD = libmoof.a
-
-
+       $(WINDRES) -o $@ -i $<
+else
 YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
-
 run: all
        $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
+endif
+
+if LINK_SH
+yoink$(EXEEXT): $(yoink_OBJECTS) $(yoink_DEPENDENCIES)
+       @rm -f yoink$(EXEEXT)
+       @LINK="$(CXXLINK) $(yoink_OBJECTS) $(yoink_LDADD) $(LIBS)"\
+               sh $(top_srcdir)/link.sh
+
+clean-local:
+       rm -f .link/*
+endif
 
This page took 0.025259 seconds and 4 git commands to generate.