]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
sockets documentation and cleanup
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..c9b5dd9bfe79714b2287628b435b4cc128f94a89 100644 (file)
@@ -1,6 +1,144 @@
 
+#
+# Yoink
+# Process this file with automake to produce a Makefile.
+#
+
+
+#
+# libmoof.a
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
+noinst_LIBRARIES = libmoof.a
+
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
+
+libmoof_a_SOURCES = \
+                                       Moof/Aabb.cc \
+                                       Moof/Aabb.hh \
+                                       Moof/Backend.cc \
+                                       Moof/Backend.hh \
+                                       Moof/Camera.cc \
+                                       Moof/Camera.hh \
+                                       Moof/Contact.hh \
+                                       Moof/ConvertUTF.c \
+                                       Moof/ConvertUTF.h \
+                                       Moof/Cullable.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
+                                       Moof/Drawable.hh \
+                                       Moof/Entity.hh \
+                                       Moof/Error.hh \
+                                       Moof/Event.hh \
+                                       Moof/Frustum.cc \
+                                       Moof/Frustum.hh \
+                                       Moof/HashTools.cc \
+                                       Moof/HashTools.hh \
+                                       Moof/Image.cc \
+                                       Moof/Image.hh \
+                                       Moof/Interpolator.hh \
+                                       Moof/Line.hh \
+                                       Moof/Log.cc \
+                                       Moof/Log.hh \
+                                       Moof/Manager.hh \
+                                       Moof/Math.hh \
+                                       Moof/ModalDialog.hh \
+                                       Moof/Network.hh \
+                                       Moof/Octree.hh \
+                                       Moof/OpenGL.hh \
+                                       Moof/Packet.cc \
+                                       Moof/Packet.hh \
+                                       Moof/Plane.cc \
+                                       Moof/Plane.hh \
+                                       Moof/Ray.hh \
+                                       Moof/Resource.cc \
+                                       Moof/Resource.hh \
+                                       Moof/RigidBody.hh \
+                                       Moof/Script.hh \
+                                       Moof/Service.cc \
+                                       Moof/Service.hh \
+                                       Moof/Settings.cc \
+                                       Moof/Settings.hh \
+                                       Moof/Shape.hh \
+                                       Moof/Socket.hh \
+                                       Moof/Sound.cc \
+                                       Moof/Sound.hh \
+                                       Moof/Sphere.hh \
+                                       Moof/StringTools.cc \
+                                       Moof/StringTools.hh \
+                                       Moof/Texture.cc \
+                                       Moof/Texture.hh \
+                                       Moof/Thread.hh \
+                                       Moof/Timer.cc \
+                                       Moof/Timer.hh \
+                                       Moof/Video.cc \
+                                       Moof/Video.hh \
+                                       Moof/View.cc \
+                                       Moof/View.hh \
+                                       Moof/fastevents.c \
+                                       Moof/fastevents.h \
+                                       $(ENDLIST)
+
+EXTRA_DIST = Moof/cml Moof/stlplus
+
+
+#
+# yoink
+#~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
+
 bin_PROGRAMS = yoink
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD = libmoof.a
+
+yoink_SOURCES = \
+                               Animation.cc \
+                               Animation.hh \
+                               Character.cc \
+                               Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
+                               GameLayer.cc \
+                               GameLayer.hh \
+                               GameState.hh \
+                               Heroine.cc \
+                               Heroine.hh \
+                               Hud.cc \
+                               Hud.hh \
+                               Main.cc \
+                               Main.hh \
+                               Scene.cc \
+                               Scene.hh \
+                               TilemapFont.cc \
+                               TilemapFont.hh \
+                               TitleLayer.cc \
+                               TitleLayer.hh \
+                               Typesetter.cc \
+                               Typesetter.hh \
+                               version.c \
+                               version.h \
+                               $(ENDLIST)
+
+if WIN32
+yoink_SOURCES += yoink.rc
+.rc.o:
+       $(WINDRES) -o $@ -i $<
+else
+YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
+run: all
+       $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
+
+debug: all
+       $(YOINK_ENVIRONMENT) gdb ./yoink
+endif
+
+if LINK_SH
+yoink$(EXEEXT): $(yoink_OBJECTS) $(yoink_DEPENDENCIES)
+       @rm -f yoink$(EXEEXT)
+       @LINK="$(CXXLINK) $(yoink_OBJECTS) $(yoink_LDADD) $(LIBS)"\
+               sh $(top_srcdir)/link.sh
+
+clean-local:
+       rm -f .link/*
+endif
 
This page took 0.025478 seconds and 4 git commands to generate.