]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
packet copy bugfix
[chaz/yoink] / src / Makefile.am
index 98cf9b91e804e3ae52377c093b9a13719352fa8c..c9b5dd9bfe79714b2287628b435b4cc128f94a89 100644 (file)
@@ -43,8 +43,11 @@ libmoof_a_SOURCES = \
                                        Moof/Manager.hh \
                                        Moof/Math.hh \
                                        Moof/ModalDialog.hh \
+                                       Moof/Network.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
+                                       Moof/Packet.cc \
+                                       Moof/Packet.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
                                        Moof/Ray.hh \
@@ -52,9 +55,12 @@ libmoof_a_SOURCES = \
                                        Moof/Resource.hh \
                                        Moof/RigidBody.hh \
                                        Moof/Script.hh \
+                                       Moof/Service.cc \
+                                       Moof/Service.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
                                        Moof/Shape.hh \
+                                       Moof/Socket.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
                                        Moof/Sphere.hh \
@@ -114,21 +120,25 @@ yoink_SOURCES = \
                                $(ENDLIST)
 
 if WIN32
-
 yoink_SOURCES += yoink.rc
-
 .rc.o:
        $(WINDRES) -o $@ -i $<
-
 else
-
 YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
-
 run: all
        $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
+endif
+
+if LINK_SH
+yoink$(EXEEXT): $(yoink_OBJECTS) $(yoink_DEPENDENCIES)
+       @rm -f yoink$(EXEEXT)
+       @LINK="$(CXXLINK) $(yoink_OBJECTS) $(yoink_LDADD) $(LIBS)"\
+               sh $(top_srcdir)/link.sh
 
+clean-local:
+       rm -f .link/*
 endif
 
This page took 0.021203 seconds and 4 git commands to generate.