]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
sockets documentation and cleanup
[chaz/yoink] / src / Makefile.am
index 4e8f65d0b26b0f47d252050332843f7e227426cd..c9b5dd9bfe79714b2287628b435b4cc128f94a89 100644 (file)
 
 noinst_LIBRARIES = libmoof.a
 
+libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
+
 libmoof_a_SOURCES = \
+                                       Moof/Aabb.cc \
                                        Moof/Aabb.hh \
+                                       Moof/Backend.cc \
+                                       Moof/Backend.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
+                                       Moof/Contact.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
-                                       Moof/Core.cc \
-                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
                                        Moof/Dispatch.cc \
                                        Moof/Dispatch.hh \
@@ -28,20 +32,22 @@ libmoof_a_SOURCES = \
                                        Moof/Event.hh \
                                        Moof/Frustum.cc \
                                        Moof/Frustum.hh \
-                                       Moof/Hash.cc \
-                                       Moof/Hash.hh \
+                                       Moof/HashTools.cc \
+                                       Moof/HashTools.hh \
                                        Moof/Image.cc \
                                        Moof/Image.hh \
                                        Moof/Interpolator.hh \
-                                       Moof/Layer.hh \
                                        Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
                                        Moof/Manager.hh \
                                        Moof/Math.hh \
                                        Moof/ModalDialog.hh \
+                                       Moof/Network.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
+                                       Moof/Packet.cc \
+                                       Moof/Packet.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
                                        Moof/Ray.hh \
@@ -49,9 +55,12 @@ libmoof_a_SOURCES = \
                                        Moof/Resource.hh \
                                        Moof/RigidBody.hh \
                                        Moof/Script.hh \
+                                       Moof/Service.cc \
+                                       Moof/Service.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
                                        Moof/Shape.hh \
+                                       Moof/Socket.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
                                        Moof/Sphere.hh \
@@ -62,15 +71,14 @@ libmoof_a_SOURCES = \
                                        Moof/Thread.hh \
                                        Moof/Timer.cc \
                                        Moof/Timer.hh \
-                                       Moof/Transition.hh \
                                        Moof/Video.cc \
                                        Moof/Video.hh \
+                                       Moof/View.cc \
+                                       Moof/View.hh \
                                        Moof/fastevents.c \
                                        Moof/fastevents.h \
                                        $(ENDLIST)
 
-libmoof_a_CPPFLAGS = -I$(top_srcdir)/src/Moof
-
 EXTRA_DIST = Moof/cml Moof/stlplus
 
 
@@ -80,6 +88,9 @@ EXTRA_DIST = Moof/cml Moof/stlplus
 
 bin_PROGRAMS = yoink
 
+yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
+yoink_LDADD = libmoof.a
+
 yoink_SOURCES = \
                                Animation.cc \
                                Animation.hh \
@@ -89,6 +100,7 @@ yoink_SOURCES = \
                                ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
+                               GameState.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
@@ -108,20 +120,25 @@ yoink_SOURCES = \
                                $(ENDLIST)
 
 if WIN32
-yoink_SOURCES += yoink.rc yoink.ico
+yoink_SOURCES += yoink.rc
 .rc.o:
-       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
-endif
-
-yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
-yoink_LDADD = libmoof.a
-
-
+       $(WINDRES) -o $@ -i $<
+else
 YOINK_ENVIRONMENT = YOINK_DATADIR="$(top_srcdir)/data"
-
 run: all
        $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
+endif
+
+if LINK_SH
+yoink$(EXEEXT): $(yoink_OBJECTS) $(yoink_DEPENDENCIES)
+       @rm -f yoink$(EXEEXT)
+       @LINK="$(CXXLINK) $(yoink_OBJECTS) $(yoink_LDADD) $(LIBS)"\
+               sh $(top_srcdir)/link.sh
+
+clean-local:
+       rm -f .link/*
+endif
 
This page took 0.02145 seconds and 4 git commands to generate.