]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
new classes; yajl library
[chaz/yoink] / src / Makefile.am
index a43fe6c150d6f5b002aeb282f172663c70578549..a026f96264b8f3e28c4c9dffe4cf547cfe2ae9a1 100644 (file)
@@ -1,6 +1,58 @@
 
-bin_PROGRAMS = yoink
+noinst_LIBRARIES = libdc.a
 
-yoink_SOURCES = yoink.cc
-yoink_LDFLAGS = -lstdc++
+libdc_a_SOURCES  = \
+                                  ConvertUTF.c \
+                                  ConvertUTF.h \
+                                  deserializer.cc \
+                                  deserializer.hh \
+                                  dispatcher.cc \
+                                  dispatcher.hh \
+                                  engine.cc \
+                                  engine.hh \
+                                  fastevents.c \
+                                  fastevents.h \
+                                  math.cc \
+                                  math.hh \
+                                  matrix.hh \
+                                  opengl.hh \
+                                  quaternion.hh \
+                                  random.cc \
+                                  random.hh \
+                                  rectangle.cc \
+                                  rectangle.hh \
+                                  serializable.cc \
+                                  serializable.hh \
+                                  serializer.cc \
+                                  serializer.hh \
+                                  settings.cc \
+                                  settings.hh \
+                                  singleton.hh \
+                                  stringtools.cc \
+                                  stringtools.hh \
+                                  texture.cc \
+                                  texture.hh \
+                                  thread.hh \
+                                  timer.cc \
+                                  timer.hh \
+                                  vector.hh \
+                                  video.cc \
+                                  video.hh \
+                                  $(ENDLIST)
+
+libdc_a_CPPFLAGS = -I/usr/include/SDL -I$(top_srcdir)/yajl/src -O3
+#libdc_a_LDFLAGS  = -lstdc++ -lSDL_image -lSDL_sound
+libdc_a_LIBADD   = $(top_srcdir)/yajl/libyajl.a
+
+
+bin_PROGRAMS   = yoink
+
+yoink_SOURCES  = \
+                                YoinkApp.cc \
+                                YoinkApp.hh \
+                                $(ENDLIST)
+
+yoink_CPPFLAGS = -I/usr/include/SDL -O3
+#yoink_LDFLAGS  = -lstdc++ -lSDL_image -lSDL_sound
+yoink_LDADD    = libdc.a ../yajl/libyajl.a
 
This page took 0.019076 seconds and 4 git commands to generate.