]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
no need to rebuild version.c every time
[chaz/yoink] / src / Makefile.am
index c10b58660c566f214cd5f2be93b85b76451373b6..766d4ce1480b0d00da9b4b63eb5d6d813dc569db 100644 (file)
@@ -19,8 +19,8 @@ libmoof_a_SOURCES = \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
                                        Moof/Cullable.hh \
-                                       Moof/Dispatcher.cc \
-                                       Moof/Dispatcher.hh \
+                                       Moof/Dispatch.cc \
+                                       Moof/Dispatch.hh \
                                        Moof/Drawable.hh \
                                        Moof/Engine.cc \
                                        Moof/Engine.hh \
@@ -34,15 +34,16 @@ libmoof_a_SOURCES = \
                                        Moof/Interpolator.hh \
                                        Moof/Layer.hh \
                                        Moof/Library.hh \
+                                       Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
                                        Moof/Math.hh \
+                                       Moof/ModalDialog.hh \
                                        Moof/Octree.hh \
                                        Moof/OpenGL.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
-                                       Moof/Random.cc \
-                                       Moof/Random.hh \
+                                       Moof/Ray.hh \
                                        Moof/Rectangle.cc \
                                        Moof/Rectangle.hh \
                                        Moof/Resource.cc \
@@ -51,9 +52,9 @@ libmoof_a_SOURCES = \
                                        Moof/Script.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
+                                       Moof/Shape.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
-                                       Moof/Sphere.cc \
                                        Moof/Sphere.hh \
                                        Moof/StringTools.cc \
                                        Moof/StringTools.hh \
@@ -85,6 +86,8 @@ yoink_SOURCES = \
                                Animation.hh \
                                Character.cc \
                                Character.hh \
+                               ErrorHandler.cc \
+                               ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
                                Heroine.cc \
@@ -103,13 +106,14 @@ yoink_SOURCES = \
                                TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
+                               version.c \
                                version.h \
                                $(ENDLIST)
 
 if WIN32
 yoink_SOURCES += yoink.rc yoink.ico
 .rc.o:
-       @WINDRES@ -o $@ -i $<
+       $(AM_V_GEN) $(WINDRES) -o $@ -i $<
 endif
 
 yoink_CPPFLAGS = -I$(top_srcdir)/src/Moof
This page took 0.018721 seconds and 4 git commands to generate.