]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
big batch of progress
[chaz/yoink] / src / Makefile.am
index 40dd17331c4d9851e0c0840d301241e99122d133..510dc9efdc278e2a32dee404ce07fd1fc91f22d8 100644 (file)
@@ -1,28 +1,33 @@
 
-noinst_LIBRARIES = libdc.a
+noinst_LTLIBRARIES = libdc.la
 
-libdc_a_SOURCES  = \
+libdc_la_SOURCES = \
                                   ConvertUTF.c \
                                   ConvertUTF.h \
+                                  aabb.hh \
+                                  animation.cc \
+                                  animation.hh \
                                   deserializer.cc \
                                   deserializer.hh \
                                   dispatcher.cc \
                                   dispatcher.hh \
+                                  drawable.hh \
                                   engine.cc \
                                   engine.hh \
+                                  event.hh \
                                   fastevents.c \
                                   fastevents.h \
-                                  math.cc \
+                                  interpolator.hh \
                                   math.hh \
-                                  matrix.hh \
+                                  mippleton.hh \
                                   opengl.hh \
-                                  quaternion.hh \
+                                  profiler.hh \
                                   random.cc \
                                   random.hh \
-                                  rectangle.cc \
-                                  rectangle.hh \
                                   resource.cc \
                                   resource.hh \
+                                  scene.cc \
+                                  scene.hh \
                                   serializable.cc \
                                   serializable.hh \
                                   serializer.cc \
@@ -35,27 +40,34 @@ libdc_a_SOURCES  = \
                                   texture.cc \
                                   texture.hh \
                                   thread.hh \
+                                  tilemap.cc \
                                   tilemap.hh \
                                   timer.cc \
                                   timer.hh \
-                                  vector.hh \
                                   video.cc \
                                   video.hh \
                                   $(ENDLIST)
 
-libdc_a_CPPFLAGS = -I/usr/include/SDL -I$(top_srcdir)/yajl/src -Wall
-#libdc_a_LDFLAGS  = -lstdc++ -lSDL_image -lSDL_sound
-libdc_a_LIBADD   = $(top_srcdir)/yajl/libyajl.a
+libdc_la_CPPFLAGS = -I/usr/include/SDL -I$(top_srcdir)/yajl/src
+libdc_la_LIBADD   = $(top_srcdir)/yajl/libyajl.la
 
 
 bin_PROGRAMS   = yoink
 
 yoink_SOURCES  = \
+                                Character.cc \
+                                Character.hh \
+                                TilemapFont.cc \
+                                TilemapFont.hh \
+                                Typesetter.cc \
+                                Typesetter.hh \
                                 YoinkApp.cc \
                                 YoinkApp.hh \
                                 $(ENDLIST)
 
-yoink_CPPFLAGS = -I/usr/include/SDL -Wall
-#yoink_LDFLAGS  = -lstdc++ -lSDL_image -lSDL_sound
-yoink_LDADD    = libdc.a libtinyxml.a ../yajl/libyajl.a
+yoink_CPPFLAGS = -I/usr/include/SDL
+yoink_LDADD    = libdc.la
+
+
+EXTRA_DIST = cml
 
This page took 0.019221 seconds and 4 git commands to generate.