]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
experimental shapes hierarchy and raycasting
[chaz/yoink] / src / Makefile.am
index f10027266a2e646c2b5f7cc5f3b97f6662af6474..e2ea2fe75e30ecf5f81151bfef2fba156088c06a 100644 (file)
@@ -34,6 +34,7 @@ libmoof_a_SOURCES = \
                                        Moof/Interpolator.hh \
                                        Moof/Layer.hh \
                                        Moof/Library.hh \
+                                       Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
                                        Moof/Math.hh \
@@ -42,6 +43,7 @@ libmoof_a_SOURCES = \
                                        Moof/OpenGL.hh \
                                        Moof/Plane.cc \
                                        Moof/Plane.hh \
+                                       Moof/Ray.hh \
                                        Moof/Rectangle.cc \
                                        Moof/Rectangle.hh \
                                        Moof/Resource.cc \
@@ -50,9 +52,9 @@ libmoof_a_SOURCES = \
                                        Moof/Script.hh \
                                        Moof/Settings.cc \
                                        Moof/Settings.hh \
+                                       Moof/Shape.hh \
                                        Moof/Sound.cc \
                                        Moof/Sound.hh \
-                                       Moof/Sphere.cc \
                                        Moof/Sphere.hh \
                                        Moof/StringTools.cc \
                                        Moof/StringTools.hh \
@@ -104,6 +106,7 @@ yoink_SOURCES = \
                                TitleLayer.hh \
                                Typesetter.cc \
                                Typesetter.hh \
+                               version.c \
                                version.h \
                                $(ENDLIST)
 
@@ -125,3 +128,6 @@ run: all
 debug: all
        $(YOINK_ENVIRONMENT) gdb ./yoink
 
+all-local:     # always rebuild version.c
+       @touch version.c
+
This page took 0.019596 seconds and 4 git commands to generate.