]> Dogcows Code - chaz/yoink/blobdiff - src/Makefile.am
destroyed global classes; view hierarchy instead
[chaz/yoink] / src / Makefile.am
index 4e8f65d0b26b0f47d252050332843f7e227426cd..c87c4126ffdff48ae4c4b8085882c5e360c93028 100644 (file)
@@ -13,12 +13,13 @@ noinst_LIBRARIES = libmoof.a
 
 libmoof_a_SOURCES = \
                                        Moof/Aabb.hh \
+                                       Moof/Backend.cc \
+                                       Moof/Backend.hh \
                                        Moof/Camera.cc \
                                        Moof/Camera.hh \
+                                       Moof/Contact.hh \
                                        Moof/ConvertUTF.c \
                                        Moof/ConvertUTF.h \
-                                       Moof/Core.cc \
-                                       Moof/Core.hh \
                                        Moof/Cullable.hh \
                                        Moof/Dispatch.cc \
                                        Moof/Dispatch.hh \
@@ -33,7 +34,6 @@ libmoof_a_SOURCES = \
                                        Moof/Image.cc \
                                        Moof/Image.hh \
                                        Moof/Interpolator.hh \
-                                       Moof/Layer.hh \
                                        Moof/Line.hh \
                                        Moof/Log.cc \
                                        Moof/Log.hh \
@@ -62,9 +62,10 @@ libmoof_a_SOURCES = \
                                        Moof/Thread.hh \
                                        Moof/Timer.cc \
                                        Moof/Timer.hh \
-                                       Moof/Transition.hh \
                                        Moof/Video.cc \
                                        Moof/Video.hh \
+                                       Moof/View.cc \
+                                       Moof/View.hh \
                                        Moof/fastevents.c \
                                        Moof/fastevents.h \
                                        $(ENDLIST)
@@ -89,6 +90,7 @@ yoink_SOURCES = \
                                ErrorHandler.hh \
                                GameLayer.cc \
                                GameLayer.hh \
+                               GameState.hh \
                                Heroine.cc \
                                Heroine.hh \
                                Hud.cc \
@@ -123,5 +125,5 @@ run: all
        $(YOINK_ENVIRONMENT) ./yoink $(YOINK_OPTS)
 
 debug: all
-       $(YOINK_ENVIRONMENT) gdb ./yoink
+       $(YOINK_ENVIRONMENT) ddd ./yoink
 
This page took 0.018836 seconds and 4 git commands to generate.