]> Dogcows Code - chaz/yoink/blobdiff - extra/yoink.ebuild
removed alut dependency
[chaz/yoink] / extra / yoink.ebuild
index f4730c18b1a4fc6b73dd7cb43b8c3f5fbbf1e9da..ce20adb3d8d755185e01e7147870a874b5635fcd 100644 (file)
@@ -7,16 +7,16 @@ EAPI=2
 inherit autotools eutils games
 
 DESCRIPTION="Alien-smashing action game"
-HOMEPAGE="http://www.dogcows.com/"
+HOMEPAGE="http://www.dogcows.com/yoink/"
 SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
        http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
 
-LICENSE="BSD-2"
+LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
-IUSE="debug profile"
+IUSE="debug double-precision gtk qt4 threads"
 
-RDEPEND="media-libs/freealut
+RDEPEND="dev-lang/lua
        media-libs/libsdl[opengl]
        media-libs/libvorbis
        media-libs/openal
@@ -27,10 +27,6 @@ DEPEND="${RDEPEND}
        dev-util/pkgconfig"
 
 src_prepare() {
-       sed -i \
-               -e "s/-Werror//g" \
-               configure.ac \
-               || die "sed failed"
        sed -i \
                -e "/apps/d" \
                -e "/pixmap/d" \
@@ -47,14 +43,16 @@ src_prepare() {
 src_configure() {
        egamesconf \
                --disable-dependency-tracking \
-               --with-assetdir="${GAMES_DATADIR}/${PN}" \
                $(use_enable debug) \
-               $(use_enable profile)
+               $(use_enable double-precision) \
+               $(use_enable gtk) \
+               $(use_enable qt4) \
+               $(use_enable threads)
 }
 
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc AUTHORS ChangeLog README TODO
+       dodoc AUTHORS ChangeLog COPYING README TODO
        doman doc/yoink.6
        doicon data/yoink.png
        make_desktop_entry ${PN} Yoink
This page took 0.022099 seconds and 4 git commands to generate.