]> Dogcows Code - chaz/yoink/blobdiff - extra/yoink.ebuild
removed alut dependency
[chaz/yoink] / extra / yoink.ebuild
index 1b3b1ba59f3d22a2dc75c3890bb97bfb74a88d00..ce20adb3d8d755185e01e7147870a874b5635fcd 100644 (file)
@@ -7,17 +7,16 @@ EAPI=2
 inherit autotools eutils games
 
 DESCRIPTION="Alien-smashing action game"
-HOMEPAGE="http://www.dogcows.com/"
+HOMEPAGE="http://www.dogcows.com/yoink/"
 SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
        http://eng.utah.edu/~mcgarvey/yoink/${P}.tar.bz2"
 
-LICENSE="BSD-2"
+LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
-IUSE="debug profile"
+IUSE="debug double-precision gtk qt4 threads"
 
 RDEPEND="dev-lang/lua
-       media-libs/freealut
        media-libs/libsdl[opengl]
        media-libs/libvorbis
        media-libs/openal
@@ -44,14 +43,16 @@ src_prepare() {
 src_configure() {
        egamesconf \
                --disable-dependency-tracking \
-               --with-assetdir="${GAMES_DATADIR}/${PN}" \
                $(use_enable debug) \
-               $(use_enable profile)
+               $(use_enable double-precision) \
+               $(use_enable gtk) \
+               $(use_enable qt4) \
+               $(use_enable threads)
 }
 
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc AUTHORS ChangeLog README TODO
+       dodoc AUTHORS ChangeLog COPYING README TODO
        doman doc/yoink.6
        doicon data/yoink.png
        make_desktop_entry ${PN} Yoink
This page took 0.020334 seconds and 4 git commands to generate.