]> Dogcows Code - chaz/yoink/blobdiff - extra/yoink.ebuild
minor build system, doc fixes
[chaz/yoink] / extra / yoink.ebuild
index 2bd8d27404400012d10efda432bd9fc0a937ce6b..a7394b310cd3deef3130e32b952c103dbd51a76d 100644 (file)
@@ -14,14 +14,14 @@ SRC_URI="http://www.dogcows.com/yoink/${P}.tar.bz2
 LICENSE="BSD-2 BSD LGPL-2.1 ZLIB"
 SLOT="0"
 KEYWORDS="amd64 ~ppc x86"
-IUSE="debug double-precision profile threads"
+IUSE="debug double-precision gtk qt4 threads"
 
 RDEPEND="dev-lang/lua
-       media-libs/freealut
+       media-libs/libpng
        media-libs/libsdl[opengl]
        media-libs/libvorbis
        media-libs/openal
-       media-libs/sdl-image[png]
+       virtual/glu
        virtual/opengl"
 DEPEND="${RDEPEND}
        dev-libs/boost
@@ -46,13 +46,14 @@ src_configure() {
                --disable-dependency-tracking \
                $(use_enable debug) \
                $(use_enable double-precision) \
-               $(use_enable profile) \
+               $(use_enable gtk) \
+               $(use_enable qt4) \
                $(use_enable threads)
 }
 
 src_install() {
        emake DESTDIR="${D}" install || die "emake install failed"
-       dodoc AUTHORS ChangeLog COPYING README TODO
+       dodoc AUTHORS COPYING README TODO
        doman doc/yoink.6
        doicon data/yoink.png
        make_desktop_entry ${PN} Yoink
This page took 0.01699 seconds and 4 git commands to generate.